summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-01 12:58:41 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-01 13:07:04 +0200
commit65862794f96de7e148b2fd5181381f09d4083aa7 (patch)
tree1e34eea7fd3590a0de14caeb1c85921bf4e724ed /games-strategy/war1gus
parentgames-strategy/wargus: Bump to 3.3.1 (diff)
downloadgentoo-65862794f96de7e148b2fd5181381f09d4083aa7.tar.gz
gentoo-65862794f96de7e148b2fd5181381f09d4083aa7.tar.bz2
gentoo-65862794f96de7e148b2fd5181381f09d4083aa7.zip
games-strategy/war1gus: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-strategy/war1gus')
-rw-r--r--games-strategy/war1gus/Manifest1
-rw-r--r--games-strategy/war1gus/war1gus-3.3.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/games-strategy/war1gus/Manifest b/games-strategy/war1gus/Manifest
index a4449166cbfc..f89f8847eba1 100644
--- a/games-strategy/war1gus/Manifest
+++ b/games-strategy/war1gus/Manifest
@@ -5,3 +5,4 @@ DIST war1gus-3.1.1.tar.gz 395477 BLAKE2B 5e304e8e2982e971c479d41b52958bc14351800
DIST war1gus-3.1.2.tar.gz 397685 BLAKE2B fabcd74d0f8622eed5f7b1c77dcbee8bee0e47bf51c5873d2565cfe200e2e21f5bbb54699cc2afd9b457e998f88b259494a3ee7394f912d6ef159f69ba8777a5 SHA512 64a6c03645cb8f0b4b8fe963e554842988efa74273a58213f047eecd322dfc77d5b4951dd4f0cb5dbd27e0c0f83d825e7fc7fd0102b83c4dbc90bee65c3d8ba1
DIST war1gus-3.2.0.tar.gz 408417 BLAKE2B 8369d380813aa6a5c7484e7b668284ee3b59bd4a914b82b074640344af977c08727260efc284a5ffc7d5c52ef7ae0ab45b484d87d855a088198b02adf5240bac SHA512 2e3509792509730254e9292dce66491e848980a37171281dcd851aaa0662a3dd8911444d97c25486acb61fa5ad913da3bb397ddd599cd7ea1293b0afbfc88bc6
DIST war1gus-3.3.0.tar.gz 486274 BLAKE2B 90675ce44cab26079c53ebd70377ea24bef3894d1f194f45496a0df6528e1bb63184f3c93f843ab9176ad02c542a9e51fbfa9f4af3bce6018fa7085d31494998 SHA512 9e17101954f7e953ba11cebd2f62eb9e3465217897bd55699846d6290fa5d249574d144f271e08485bc38ef7dd63e5efa05437faa5191148d1ea9341157834ea
+DIST war1gus-3.3.1.tar.gz 486322 BLAKE2B cdf3db536c6cae2327ba044da13f2743c299481503723d00fbfeb8103932a0065afb0771f1719264fa7ed298b876f2189bc9c1def2b4fcc6c1b4a45992d0d322 SHA512 947592a220aeae99840abc88c5086d681afb72971f25f3e42c475d416529bb0341ca409aa5459e049d1dbe4b937cf25c29c6445958c5c61e26a67c4a4dd7ccb0
diff --git a/games-strategy/war1gus/war1gus-3.3.1.ebuild b/games-strategy/war1gus/war1gus-3.3.1.ebuild
new file mode 100644
index 000000000000..d61b049b1854
--- /dev/null
+++ b/games-strategy/war1gus/war1gus-3.3.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Warcraft: Orcs & Humans for the Stratagus game engine"
+HOMEPAGE="
+ https://stratagus.com/war1gus.html
+ https://github.com/Wargus/war1gus/
+"
+SRC_URI="
+ https://github.com/Wargus/war1gus/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ =games-engines/stratagus-${PV}*[theora]
+ media-libs/libpng:0=
+ sys-libs/zlib:=
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGAMEDIR="${EPREFIX}/usr/bin"
+ -DBINDIR="${EPREFIX}/usr/bin"
+ -DSTRATAGUS="${EPREFIX}/usr/bin/stratagus"
+ -DSHAREDIR="${EPREFIX}/usr/share/stratagus/war1gus"
+ -DICONDIR=/usr/share/icons/hicolor/64x64/apps
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "War1gus requires the data from the original game to run. The game"
+ elog "will ask you for the location of the game data and extract/convert"
+ elog "it automatically on the first run."
+
+ if ! has_version media-video/ffmpeg ||
+ ! has_version media-sound/timidity++
+ then
+ elog
+ elog "If you did not convert the game data yet, you may want to install"
+ elog "the following optional dependencies:"
+ elog
+ elog "media-video/ffmpeg -- to convert game videos"
+ elog "media-sound/timidity++ -- to convert game music"
+ fi
+
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}