summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/warmux/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/warmux/files')
-rw-r--r--games-strategy/warmux/files/warmux-11.04.1-action.patch12
-rw-r--r--games-strategy/warmux/files/warmux-11.04.1-gcc47.patch11
-rw-r--r--games-strategy/warmux/files/warmux-11.04.1-gentoo.patch40
-rw-r--r--games-strategy/warmux/files/warmux-11.04.1-stat.patch61
-rw-r--r--games-strategy/warmux/files/warmux-11.04.1-zlib.patch11
5 files changed, 135 insertions, 0 deletions
diff --git a/games-strategy/warmux/files/warmux-11.04.1-action.patch b/games-strategy/warmux/files/warmux-11.04.1-action.patch
new file mode 100644
index 000000000000..e1530337a259
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.04.1-action.patch
@@ -0,0 +1,12 @@
+diff -uNr warmux-11.04.orig/lib/warmux/action/action.cpp warmux-11.04/lib/warmux/action/action.cpp
+--- warmux-11.04.orig/lib/warmux/action/action.cpp 2012-03-27 15:18:08.440709875 +0200
++++ warmux-11.04/lib/warmux/action/action.cpp 2012-03-27 15:17:44.871711354 +0200
+@@ -85,7 +85,7 @@
+ {
+ m_creator = _creator;
+
+- m_header.len = SDLNet_Read32(buffer);
++ m_header.len = SDLNet_Read32((void *)buffer);
+ ASSERT(m_header.len >= sizeof(Header));
+ buffer += 4;
+ // All of the following could be skipped for the actions we now, \ No newline at end of file
diff --git a/games-strategy/warmux/files/warmux-11.04.1-gcc47.patch b/games-strategy/warmux/files/warmux-11.04.1-gcc47.patch
new file mode 100644
index 000000000000..8460bcbd0b1c
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.04.1-gcc47.patch
@@ -0,0 +1,11 @@
+Description: Fix FTBFS with gcc 4.7.
+Author: Felix Geyer <debfx-pkg@fobos.de>
+
+--- warmux-11.04.1+repack.orig/tools/list_games/main.cpp
++++ warmux-11.04.1+repack/tools/list_games/main.cpp
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <unistd.h>
+ #include <WARMUX_types.h>
+ #include <WARMUX_network.h>
+ #include <WARMUX_index_server.h>
diff --git a/games-strategy/warmux/files/warmux-11.04.1-gentoo.patch b/games-strategy/warmux/files/warmux-11.04.1-gentoo.patch
new file mode 100644
index 000000000000..62d22f84c82d
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.04.1-gentoo.patch
@@ -0,0 +1,40 @@
+diff -ru warmux-11.04.orig/configure.ac warmux-11.04/configure.ac
+--- warmux-11.04.orig/configure.ac 2011-04-18 16:46:12.000000000 -0400
++++ warmux-11.04/configure.ac 2011-04-19 11:17:27.380256500 -0400
+@@ -43,8 +43,6 @@
+ AC_MSG_ERROR([*** No C++ compiler can be found!])
+ fi
+
+-AX_CFLAGS_WARN_ALL([CXXFLAGS])
+-
+ # ==========================================================================
+ # == Set flags for various environments =
+ # ==========================================================================
+@@ -348,14 +346,9 @@
+ exit 1
+ fi
+
+-dnl === Add Werror flag for gcc/g++ if debug mode is enabled, ==============
+-dnl === but allow RTTI (ie dynamic_cast, typeid/typeinfo unavailable) ======
+-if test "x${debug}" = "xyes"; then
++if test "x${debug}" != "xyes"; then
+- CFLAGS="$CFLAGS -Werror"
+- CXXFLAGS="$CXXFLAGS -Werror"
+-else
+ CXXFLAGS="$CXXFLAGS -fno-rtti"
+ fi
+
+ dnl === Forbid exceptions (Android platform requirement) ===================
+ CXXFLAGS="$CXXFLAGS -fno-exceptions"
+diff -ru warmux-11.04.orig/data/Makefile.am warmux-11.04/data/Makefile.am
+--- warmux-11.04.orig/data/Makefile.am 2011-04-18 16:46:11.000000000 -0400
++++ warmux-11.04/data/Makefile.am 2011-04-19 11:17:45.134724536 -0400
+@@ -1,8 +1,2 @@
+-xdg_appsdir = $(prefix)/share/applications
+-xdg_apps_DATA = warmux.desktop warmux_files.desktop
+-pixmapsdir = $(prefix)/share/pixmaps
+-pixmaps_DATA = icon/warmux_128x128.png
+-
+ nobase_dist_pkgdata_DATA = @DATA_FILES@
+ pkgdatadir = @DATADIR@
+-EXTRA_DIST = $(pixmaps_DATA)
diff --git a/games-strategy/warmux/files/warmux-11.04.1-stat.patch b/games-strategy/warmux/files/warmux-11.04.1-stat.patch
new file mode 100644
index 000000000000..487b3805ba6f
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.04.1-stat.patch
@@ -0,0 +1,61 @@
+diff -ur warmux-11.04.orig/lib/warmux/tools/file_tools.cpp warmux-11.04/lib/warmux/tools/file_tools.cpp
+--- warmux-11.04.orig/lib/warmux/tools/file_tools.cpp 2011-04-28 21:03:13.000000000 +0200
++++ warmux-11.04/lib/warmux/tools/file_tools.cpp 2013-03-05 16:58:42.040443845 +0100
+@@ -33,6 +33,8 @@
+ # include <direct.h>
+ # undef DeleteFile // windows.h defines it I think
+ #else
++# include <sys/types.h>
++# include <sys/stat.h>
+ # include <stdlib.h> // getenv
+ # include <unistd.h> // not needed by mingw
+ #endif
+@@ -275,18 +277,14 @@
+ {
+ DIR *dir;
+ struct dirent *file;
+-#ifdef __SYMBIAN32__
+ std::string dname;
+-#endif
+ };
+
+ FolderSearch* OpenFolder(const std::string& dirname)
+ {
+ FolderSearch *f = new FolderSearch;
+ f->dir = opendir(dirname.c_str());
+-#ifdef __SYMBIAN32__
+ f->dname = dirname;
+-#endif
+
+ if (!f->dir) {
+ delete f;
+@@ -300,11 +298,11 @@
+ {
+ while ((f->file = readdir(f->dir)) != NULL) {
+
++ if (
+ #ifdef __SYMBIAN32__
+- if (f->file->d_namlen && DoesFolderExist(f->dname+"/"+std::string(f->file->d_name))) {
+-#else
+- if (f->file->d_type == DT_DIR) {
++ f->file->d_namlen &&
+ #endif
++ DoesFolderExist(f->dname+"/"+std::string(f->file->d_name))) {
+ // If we are also looking for files, report it isn't one
+ if (file)
+ file = false;
+@@ -316,11 +314,11 @@
+ continue;
+
+ // This is a file and we do search for file
++ if (
+ #ifdef __SYMBIAN32__
+- if (f->file->d_namlen && DoesFileExist(f->dname+"/"+std::string(f->file->d_name))) {
+-#else
+- if (f->file->d_type == DT_REG) {
++ f->file->d_namlen &&
+ #endif
++ DoesFileExist(f->dname+"/"+std::string(f->file->d_name))) {
+ file = true;
+ return f->file->d_name;
+ }
diff --git a/games-strategy/warmux/files/warmux-11.04.1-zlib.patch b/games-strategy/warmux/files/warmux-11.04.1-zlib.patch
new file mode 100644
index 000000000000..c7e77aba11c8
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.04.1-zlib.patch
@@ -0,0 +1,11 @@
+diff -uNr warmux-11.04.orig/src/graphic/surface.cpp warmux-11.04/src/graphic/surface.cpp
+--- warmux-11.04.orig/src/graphic/surface.cpp 2011-09-19 09:26:52.392650465 +0200
++++ warmux-11.04/src/graphic/surface.cpp 2011-09-19 09:26:19.417648189 +0200
+@@ -25,6 +25,7 @@
+ #include <SDL_image.h>
+ #include <SDL_rotozoom.h>
+ #include <png.h>
++#include <zlib.h>
+
+ #include "graphic/surface.h"
+ #include "tool/math_tools.h"