summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/widelands/widelands-0.17.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/widelands/widelands-0.17.ebuild')
-rw-r--r--games-strategy/widelands/widelands-0.17.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/games-strategy/widelands/widelands-0.17.ebuild b/games-strategy/widelands/widelands-0.17.ebuild
new file mode 100644
index 000000000000..9a4e1caa8866
--- /dev/null
+++ b/games-strategy/widelands/widelands-0.17.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils versionator toolchain-funcs flag-o-matic cmake-utils games
+
+MY_PV=build$(get_version_component_range 2)
+MY_P=${PN}-${MY_PV}-src
+DESCRIPTION="A game similar to Settlers 2"
+HOMEPAGE="http://www.widelands.org/"
+SRC_URI="http://launchpad.net/widelands/${MY_PV}/build-$(get_version_component_range 2)/+download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-lang/lua
+ media-libs/libsdl[video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-gfx
+ media-libs/sdl-net
+ media-libs/libpng
+ sys-libs/zlib
+ media-libs/glew
+ media-libs/sdl-ttf
+ >=dev-libs/boost-1.37"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+CMAKE_BUILD_TYPE=Release
+PREFIX=${GAMES_DATADIR}/${PN}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-cxxflags.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+
+ sed -i -e 's:__ppc__:__PPC__:' src/s2map.cc || die
+ sed -i -e '74i#define OF(x) x' src/io/filesystem/{un,}zip.h || die
+ sed -i -e '22i#define OF(x) x' src/io/filesystem/ioapi.h || die
+ sed -i -e '/Boost_USE_STATIC_LIBS/s:ON:OFF:' CMakeLists.txt || die
+
+ # how do I hate boost? Let me count the ways...
+ local boost_ver=$(best_version ">=dev-libs/boost-1.37")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
+}
+
+src_configure() {
+ local mycmakeargs+=(
+ '-DWL_VERSION_STANDARD=true'
+ "-DWL_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DWL_INSTALL_DATADIR=${GAMES_DATADIR}/${PN}"
+ "-DWL_INSTALL_LOCALEDIR=${GAMES_DATADIR}/${PN}/locale"
+ "-DWL_INSTALL_BINDIR=${GAMES_BINDIR}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon pics/wl-ico-128.png ${PN}.png
+ make_desktop_entry ${PN} Widelands
+ dodoc ChangeLog CREDITS
+ prepgamesdirs
+}