summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2021-08-27 13:25:02 +0200
committerSam James <sam@gentoo.org>2021-08-28 04:01:58 +0100
commit022cb8098bf4a77a24c5014805b45712a67825fa (patch)
tree875732f2bf76f3727e781e6a54630b3420224f7c /games-strategy
parentgames-strategy/0ad: Bump to alpha25b and EAPI=8 (diff)
downloadgentoo-022cb8098bf4a77a24c5014805b45712a67825fa.tar.gz
gentoo-022cb8098bf4a77a24c5014805b45712a67825fa.tar.bz2
gentoo-022cb8098bf4a77a24c5014805b45712a67825fa.zip
games-strategy/0ad: Remove a25 (superceded by a25b)
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Nils Freydank <holgersson@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/22118 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/0ad/0ad-0.0.25_alpha.ebuild221
-rw-r--r--games-strategy/0ad/Manifest2
2 files changed, 0 insertions, 223 deletions
diff --git a/games-strategy/0ad/0ad-0.0.25_alpha.ebuild b/games-strategy/0ad/0ad-0.0.25_alpha.ebuild
deleted file mode 100644
index c4b1cf74eb71..000000000000
--- a/games-strategy/0ad/0ad-0.0.25_alpha.ebuild
+++ /dev/null
@@ -1,221 +0,0 @@
-# Copyright 2014-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-WX_GTK_VER="3.0-gtk3"
-PYTHON_COMPAT=( python3_{7..9} )
-inherit desktop toolchain-funcs multiprocessing python-any-r1 wxwidgets xdg
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/0ad/0ad"
- S="${WORKDIR}/${P}"
-elif [[ ${PV} == *_pre* ]]; then
- ZEROAD_GIT_REVISION="c7d07d3979f969b969211a5e5748fa775f6768a7"
- SRC_URI="https://github.com/0ad/0ad/archive/${ZEROAD_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${ZEROAD_GIT_REVISION}"
-else
- MY_P="0ad-${PV/_/-}"
- SRC_URI="
- http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz
- https://releases.wildfiregames.com/${MY_P}-unix-data.tar.xz
- "
- S="${WORKDIR}/${MY_P}"
-fi
-
-DESCRIPTION="A free, real-time strategy game"
-HOMEPAGE="https://play0ad.com/"
-LICENSE="BitstreamVera CC-BY-SA-3.0 GPL-2 LGPL-2.1 LPPL-1.3c MIT ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="editor +lobby nvtt pch test"
-RESTRICT="test"
-CHECKREQS_DISK_BUILD="9000M" # 8779624 KiB (8.3 GiB)
-CHECKREQS_DISK_USR="3500M" # 3545840 KiB (3.3 GiB)
-# Premake adds '-s' to some LDFLAGS. Simply sed'ing it out leads to
-# build and/or startup issues.
-QA_PRESTRIPPED="/usr/lib64/0ad/libCollada.so /usr/bin/0ad"
-
-# virtual/rust is for bundled SpiderMonkey
-# Build-time Python dependency is for SM, too.
-# TODO: Unbundle premake5
-# See bug #773472 which may help (bump for it)
-BDEPEND="
- ${PYTHON_DEPS}
- >=dev-util/premake-5.0.0_alpha12:5
- virtual/pkgconfig
- virtual/rust
- test? ( dev-lang/perl )
-"
-# Removed dependency on nvtt as we use the bundled one
-# bug #768930
-DEPEND="
- dev-libs/boost:=
- dev-libs/icu:=
- dev-libs/libfmt:0=
- dev-libs/libsodium
- dev-libs/libxml2
- media-libs/libpng:0
- media-libs/libsdl2[X,opengl,video]
- media-libs/libvorbis
- media-libs/openal
- net-libs/enet:1.3
- net-libs/miniupnpc:=
- net-misc/curl
- sys-libs/zlib
- virtual/opengl
- x11-libs/libX11
- editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
- lobby? ( net-libs/gloox )
-"
-RDEPEND="
- ${DEPEND}
- !games-strategy/0ad-data
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.0.24b_alpha-respect-tc.patch
-)
-
-pkg_setup() {
- use editor && setup-wxwidgets
-}
-
-src_prepare() {
- default
-
- # SpiderMonkey's configure no longer recognises --build for
- # the build tuple
- sed -i -e "/--build/d" libraries/source/spidermonkey/build.sh || die
-
- # Originally from 0ad-data
- rm binaries/data/tools/fontbuilder/fonts/*.txt || die
-}
-
-src_configure() {
- # 0AD uses premake:5 to generate the Makefiles, so let's
- # 1. configure the configure args,
- # 2. export some toolchain args,
- # 3. configure premake args,
- # 4. run premake5.
- local myconf=(
- --minimal-flags
- $(usex nvtt "" "--without-nvtt")
- $(usex pch "" "--without-pch")
- $(usex test "" "--without-tests")
- $(usex editor "--atlas" "")
- $(usex lobby "" "--without-lobby")
- --bindir="/usr/bin"
- --libdir="/usr/$(get_libdir)"/${PN}
- --datadir="/usr/share/${PN}"
- )
-
- tc-export AR CC CXX RANLIB
-
- local mypremakeargs=(
- --outpath="../workspace/gcc"
- --os=linux
- --verbose
- )
-
- cd "${S}/build/premake" || die "Could not enter premake directory"
-
- /usr/bin/premake5 "${mypremakeargs[@]}" "${myconf[@]}" gmake2 \
- || die "Premake failed"
-}
-
-src_compile() {
- # Build 3rd party fcollada
- einfo "Building bundled fcollada"
- emake -C libraries/source/fcollada/src
-
- # Build bundled NVTT
- # nvtt is abandoned upstream and 0ad has forked it and added fixes.
- # Use their copy. bug #768930
- if use nvtt ; then
- cd libraries/source/nvtt || die
- elog "Building bundled NVTT (bug #768930)"
- JOBS="-j$(makeopts_jobs)" ./build.sh || die "Failed to build bundled NVTT"
- cd "${S}" || die
- fi
-
- # Build bundled SpiderMonkey
- # We really can't use the system SpiderMonkey right now.
- # Breakages occur even on minor bumps in upstream SM,
- # e.g. bug #768840.
- cd libraries/source/spidermonkey || die
- elog "Building bundled SpiderMonkey (bug #768840)"
- XARGS="${EPREFIX}/usr/bin/xargs" \
- JOBS="-j$(makeopts_jobs)" \
- ./build.sh \
- || die "Failed to build bundled SpiderMonkey"
-
- cd "${S}" || die
-
- # Build 0ad itself!
- elog "Building 0ad"
- JOBS="-j$(makeopts_jobs)" emake -C build/workspace/gcc verbose=1
-
- # Build assets
- # (We only do this if we're using a snapshot/non-release)
- # See bug #771147 (comment 3) and the old 0ad-data ebuild
- # Warning: fragile!
- if [[ ${PV} == 9999 || ${PV} == *_pre* ]]; then
- # source/lib/sysdep/os/linux/ldbg.cpp:debug_SetThreadName() tries to open /proc/self/task/${TID}/comm for writing.
- addpredict /proc/self/task
-
- # Based on source/tools/dist/build-archives.sh used by source/tools/dist/build.sh.
- local archivebuild_input archivebuild_output mod_name
- for archivebuild_input in binaries/data/mods/[A-Za-z0-9]*; do
- mod_name="${archivebuild_input##*/}"
- archivebuild_output="archives/${mod_name}"
-
- mkdir -p "${archivebuild_output}" || die
-
- einfo pyrogenesis -archivebuild="${archivebuild_input}" -archivebuild-output="${archivebuild_output}/${mod_name}.zip"
- LD_LIBRARY_PATH="binaries/system" binaries/system/pyrogenesis \
- -archivebuild="${archivebuild_input}" \
- -archivebuild-output="${archivebuild_output}/${mod_name}.zip" \
- || die "Failed to build assets"
-
- if [[ -f "${archivebuild_input}/mod.json" ]]; then
- cp "${archivebuild_input}/mod.json" "${archivebuild_output}" || die
- fi
-
- rm -r "${archivebuild_input}" || die
- mv "${archivebuild_output}" "${archivebuild_input}" || die
- done
-
- # Based on source/tools/dist/build-unix-win32.sh used by source/tools/dist/build.sh.
- rm binaries/data/config/dev.cfg || die
- rm -r binaries/data/mods/_test.* || die
- fi
-}
-
-src_test() {
- cd binaries/system || die
- ./test -libdir "${S}/binaries/system" || die "Failed tests"
-}
-
-src_install() {
- newbin binaries/system/pyrogenesis 0ad
- use editor && newbin binaries/system/ActorEditor 0ad-ActorEditor
-
- # Merged from 0ad-data
- # bug #771147 (comment 3)
- insinto /usr/share/${PN}
- doins -r binaries/data/{l10n,config,mods,tools}
-
- # Install bundled SpiderMonkey and nvtt
- # bug #771147 (comment 1)
- exeinto /usr/$(get_libdir)/${PN}
- doexe binaries/system/{libCollada,libmozjs78-ps-release}.so
-
- use nvtt && doexe binaries/system/{libnvtt,libnvcore,libnvimage,libnvmath}.so
- use editor && doexe binaries/system/libAtlasUI.so
-
- dodoc binaries/system/readme.txt
- doicon -s 128 build/resources/${PN}.png
- make_desktop_entry ${PN}
-}
diff --git a/games-strategy/0ad/Manifest b/games-strategy/0ad/Manifest
index 3adb1e76c5e5..923eae80585e 100644
--- a/games-strategy/0ad/Manifest
+++ b/games-strategy/0ad/Manifest
@@ -1,7 +1,5 @@
DIST 0ad-0.0.24b-alpha-unix-build.tar.xz 75546740 BLAKE2B a724abba6bed4b580670588e9dcfe0f75f6cef0fbde6ad666356e96213c685932edd0a1daafb5dd04206870c2c8222340c9c51e83076ec2911cbb5377ca00666 SHA512 8173d393eb1bc57c38bef0076ba973ef46c877c06644365189c0887cd3152adba51d26b553e42221fd14343e9830a3a275bfcd9b28f66281e282ea3f247730ea
DIST 0ad-0.0.24b-alpha-unix-data.tar.xz 828553992 BLAKE2B 2081225d88d475ed0899648994a900677bc3280bb2ba6cf92354ece82b90ddcefddb48458fa23e2de97100e58f4db8db408d4b50d0306a8c3efe47d263064bf0 SHA512 d7804d25ddf376028f230a31c6fc1201dfa366b3d5434569a1a7852bb4c400fb14e5c8934c5d6c6295320cf2e62c64be83b1e3c4c27fd116115bfe7d01106726
-DIST 0ad-0.0.25-alpha-unix-build.tar.xz 75788348 BLAKE2B 49b8b99a8f2fd33d4a3c2c0320375cb372d23b2f2c0f4ba56438bc8d868891c8c8c624049e3165ec84f8b98bcb1e1195b672aa7ee258ff88317af9d4da883576 SHA512 a8edae7d2dd61972b947152edda8d9ca8bafd3d435623a94de2d1297ecad3bfc73d3b30eaff98e89a6bcb0291b49f1e25bae1300fde37c8989156c895cd12730
-DIST 0ad-0.0.25-alpha-unix-data.tar.xz 1272283892 BLAKE2B 7bc08e52b44129fce6a78914d36bcb0c8bb3312645982054274e230a23edc34f9aa899d7ca8f52f3044b8c7efd0aea4b5d16fcd9d6e20e274538007885cfa1c2 SHA512 92fad341ceb1156a3facea291856ca2f719691bba1cf085de0544f3ae9300f46391efdd1c88bcf1aafd9a9c938b6bef3babbd50c850dc17fb0c9609dbabe37ad
DIST 0ad-0.0.25b-alpha-unix-build.tar.xz 75579956 BLAKE2B 674d69d625137709a186f9273607dc353fc99aea68ef3f2ea5031dbe2f684176910d757c3f03c7fbdac475d30708be448b71f5020d27a65c346bf147223bcb9d SHA512 e8069897b97b381099ab5ec5868d27e96c699105b3307054d1bc7bf9236a537f02625ba9034892d91f3e951b4f95c9ce5fb75ed0a7c14b8a294882482fd9c1b4
DIST 0ad-0.0.25b-alpha-unix-build.tar.xz.minisig 327 BLAKE2B 547a7a1c8a83167fa40976efb2efaf691fc5434eb1be227b481a70d308381b20dcdc90bb4652e190f8e329fb33cc19ebbaab43977329f8971e49436f7f1ce636 SHA512 9d6a235ea50183e1db16f4bf2dc59af9042a52e4e18ccd0c34c481a7e9021f19e2bc370e594aa97911bb7ca33bcc5ebe23a4b206cd74357060371ca06b6010d2
DIST 0ad-0.0.25b-alpha-unix-data.tar.xz 1249684600 BLAKE2B d77546ba9d21b512f106645c07fa92ecc343e0a01d9a70a83f2a2b3ade912e72d095982f7d4c4cd64e18fb71a67a01c419763744dd4cad1e8c081e5f77ec17c9 SHA512 d6bbe484acb7fbd507d303f5c75f8a2ccbaf8fe9dd30ff408b082f170bfd96eb9235db1b710c15656ef465b44fa5597679a694515e0c153a35fe24c0915f29f1