summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-19 14:01:10 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-19 16:32:04 +0100
commit3111377937bc7ae35ec874cb6e35573061be424c (patch)
tree5e141318b3ee825494b2ff1f69588b290f4c0389 /games-strategy
parentsys-kernel/gentoo-kernel: Bump to 5.9.15 (diff)
downloadgentoo-3111377937bc7ae35ec874cb6e35573061be424c.tar.gz
gentoo-3111377937bc7ae35ec874cb6e35573061be424c.tar.bz2
gentoo-3111377937bc7ae35ec874cb6e35573061be424c.zip
games-strategy/war1gus: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/war1gus/Manifest1
-rw-r--r--games-strategy/war1gus/war1gus-3.0.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/games-strategy/war1gus/Manifest b/games-strategy/war1gus/Manifest
index 3e030e66acef..27c10be561cd 100644
--- a/games-strategy/war1gus/Manifest
+++ b/games-strategy/war1gus/Manifest
@@ -1 +1,2 @@
DIST war1gus-2.4.3.tar.gz 436938 BLAKE2B 662c3e2d16d4ca3225a50ec28ff6ae11f9c309a02c1b71e26a28155012395091dec7833a4f32a0ee6c19119a9c0aa2aa96cb465b06937da8efdd54b040189778 SHA512 909dc3375a00a4ff05eb287e6a1e3414b084f51cda37fe73ab4d728eb2d13e3e0e8612700a90e000d67a9ddffb115fe41554a4ad9db9f68e0b62cdbc0d025ae0
+DIST war1gus-3.0.0.tar.gz 446245 BLAKE2B f58d8fe8248cc7cc661a5c2dabef9b13410eb3530bb045c03c54abeea8028e26ada3bd98d50680165b3ce35b17a08acba2b953b8c896de990cdbb3acf59cd4ae SHA512 fad712945e939fededf202181523b34945ba58ded5b5ea8089709860b63ad9c9766eb926293e5195c14f0dc3b8531ac0ae4654ab6b6718068648f9efc0fb817c
diff --git a/games-strategy/war1gus/war1gus-3.0.0.ebuild b/games-strategy/war1gus/war1gus-3.0.0.ebuild
new file mode 100644
index 000000000000..7871af95da19
--- /dev/null
+++ b/games-strategy/war1gus/war1gus-3.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Warcraft: Orcs & Humans for the Stratagus game engine"
+HOMEPAGE="https://wargus.github.io/war1gus.html
+ https://github.com/Wargus/war1gus"
+SRC_URI="https://github.com/Wargus/war1gus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ =games-engines/stratagus-${PV}*[theora]
+ media-libs/libpng:0=
+ sys-libs/zlib:=
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGAMEDIR="${EPREFIX}/usr/bin"
+ -DBINDIR="${EPREFIX}/usr/bin"
+ -DSTRATAGUS="${EPREFIX}/usr/bin/stratagus"
+ -DSHAREDIR="${EPREFIX}/usr/share/stratagus/war1gus"
+ -DICONDIR=/usr/share/icons/hicolor/64x64/apps
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "War1gus requires the data from the original game to run. The game"
+ elog "will ask you for the location of the game data and extract/convert"
+ elog "it automatically on the first run."
+
+ if ! has_version media-video/ffmpeg ||
+ ! has_version media-sound/timidity++
+ then
+ elog
+ elog "If you did not convert the game data yet, you may want to install"
+ elog "the following optional dependencies:"
+ elog
+ elog "media-video/ffmpeg -- to convert game videos"
+ elog "media-sound/timidity++ -- to convert game music"
+ fi
+
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}