summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-08-24 15:58:32 +0200
committerPacho Ramos <pacho@gentoo.org>2023-08-24 16:00:01 +0200
commit420dd1b3e2566e5bd88b29dd29812d057ba89f63 (patch)
tree2c7c60a00497324d1b2202c110fcf12965ca13f5 /games-strategy
parentgames-strategy/wesnoth: add 1.16.10 (diff)
downloadgentoo-420dd1b3e2566e5bd88b29dd29812d057ba89f63.tar.gz
gentoo-420dd1b3e2566e5bd88b29dd29812d057ba89f63.tar.bz2
gentoo-420dd1b3e2566e5bd88b29dd29812d057ba89f63.zip
games-strategy/wesnoth: add 1.17.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/Manifest1
-rw-r--r--games-strategy/wesnoth/wesnoth-1.17.20.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 46bb23272a14..4257802e4705 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -3,3 +3,4 @@ DIST wesnoth-1.16.8.tar.gz 518468407 BLAKE2B 9c224757e0d1727acc66a5421266fa6e050
DIST wesnoth-1.16.9.tar.gz 518511920 BLAKE2B bc9bfa9b514e72ce732a4256f765976f5be806d12dd962b2b396ffa8646acaa84c1bb1f4b20368886579782f8236c0d71f296bb5bd2451d4b0d8f6ce46bc3a18 SHA512 313aaad95c66757a952c00f1e5a515ce61bcf7564d6555802bc2619714d038a9a5607f3395e3e8afe5f216205e5b9b07b651789a749b4de37b30f8b8a47cb47f
DIST wesnoth-1.17.17.tar.bz2 423574966 BLAKE2B 08bcc889333a74b45882f0b1a87960f333eb833c135429f19e3e5805206a45d6e890baa5b2b944d54e8aa088295bcf697c592d96703ee1fb49314e080f3949d8 SHA512 721edb885f5f215d679f50ae5ec34c11631771d248320617d55808580f4d1ab22d24b5a4e4001113ad8990b2e0f4e13d64a97a57de30d5453bd82e54ee7949aa
DIST wesnoth-1.17.19.tar.bz2 424402790 BLAKE2B bfb594b2c6421f8c553fda4db7ee9df57f7a5c9ed5589354c5360abe8e7d155720c9b904e8c480ade106308e4e0202ee209bb2550455a45b2dd4dc4a32428c14 SHA512 4c43d462a512525640448069c14bb0690ba3bddba793568810c1f3a3af6b26caa922d5e893b6ec5579f23ed244e4cce6604fbc9aa162809050422fe0e44364e4
+DIST wesnoth-1.17.20.tar.bz2 424613262 BLAKE2B acf8b6a9213b1fea9370c76cc7e63001fa34777357ab791db8380ca684195e830385939d0e31fbb058e5c84ebce74f084d9884bdf27d1ecb662e28dbcb477dab SHA512 b7eaaf624e84b28eca7d702a791fbe7c6b9e833d3e4f9d61ee79c70737ec396b81b2cefedae0ef272ec5384d71c28a4b083bf837591f6ce2c345d79f43b1e87e
diff --git a/games-strategy/wesnoth/wesnoth-1.17.20.ebuild b/games-strategy/wesnoth/wesnoth-1.17.20.ebuild
new file mode 100644
index 000000000000..b4c9db3eeff1
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.17.20.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org
+ https://github.com/wesnoth/wesnoth"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# uneven minor versions are development versions
+if [[ $(( $(ver_cut 2) % 2 )) == 0 ]] ; then
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+IUSE="dbus dedicated doc nls server"
+
+RDEPEND="
+ acct-group/wesnoth
+ acct-user/wesnoth
+ dev-libs/boost:=[bzip2,context,icu,nls]
+ >=media-libs/libsdl2-2.0.4:0[joystick,video,X]
+ !dedicated? (
+ dev-libs/glib:2
+ dev-libs/openssl:0=
+ >=media-libs/fontconfig-2.4.1
+ >=media-libs/sdl2-image-2.0.0[jpeg,png,webp]
+ >=media-libs/sdl2-mixer-2.0.0[vorbis]
+ media-libs/libvorbis
+ >=x11-libs/pango-1.22.0
+ >=x11-libs/cairo-1.10.0
+ sys-libs/readline:0=
+ dbus? ( sys-apps/dbus )
+ )"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if ! use doc ; then
+ sed -i \
+ -e '/manual/d' \
+ doc/CMakeLists.txt || die
+ fi
+
+ # respect LINGUAS (bug #483316)
+ if [[ ${LINGUAS+set} ]] ; then
+ local lang langs=()
+ for lang in $(cat po/LINGUAS) ; do
+ has ${lang} ${LINGUAS} && langs+=( ${lang} )
+ done
+ echo "${langs[@]}" > po/LINGUAS || die
+ fi
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+
+ local mycmakeargs=()
+
+ if use dedicated || use server ; then
+ mycmakeargs+=(
+ -DENABLE_CAMPAIGN_SERVER="ON"
+ -DENABLE_SERVER="ON"
+ -DSERVER_UID="${PN}"
+ -DSERVER_GID="${PN}"
+ -DFIFO_DIR="/run/wesnothd"
+ )
+ else
+ mycmakeargs+=(
+ -DENABLE_CAMPAIGN_SERVER="OFF"
+ -DENABLE_SERVER="OFF"
+ )
+ fi
+ mycmakeargs+=(
+ -Wno-dev
+ -DENABLE_GAME="$(usex !dedicated)"
+ -DENABLE_DESKTOP_ENTRY="$(usex !dedicated)"
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_NOTIFICATIONS="$(usex dbus)"
+ -DENABLE_STRICT_COMPILATION="OFF"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ local DOCS=( README.md changelog.md )
+ cmake_src_install
+ if use dedicated || use server ; then
+ rmdir "${ED}"/run{/wesnothd,} || die
+ newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
+ fi
+}