summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-06 23:59:40 +0000
committerSam James <sam@gentoo.org>2022-01-07 00:01:43 +0000
commit466dd3ad91db9f2259c687f52f87835e45e191b9 (patch)
tree11e421cdd5c8e214382f6b8fbcb4713758720263 /games-strategy
parentdev-python/pygments: Keyword 2.11.2 for ~m68k (diff)
downloadgentoo-466dd3ad91db9f2259c687f52f87835e45e191b9.tar.gz
gentoo-466dd3ad91db9f2259c687f52f87835e45e191b9.tar.bz2
gentoo-466dd3ad91db9f2259c687f52f87835e45e191b9.zip
games-strategy/endless-sky: don't compress man page; use system catch2
- Don't compress man page - Use system copy of Catch 2 for tests (works w/ glibc-2.34 now, didn't notice earlier b/c tested on a stable box); still not running tests yet, need to resolve linking issue. - Respect AR Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/endless-sky/endless-sky-0.9.14.ebuild9
-rw-r--r--games-strategy/endless-sky/files/endless-sky-0.9.14-dont-compress-man-page.patch20
-rw-r--r--games-strategy/endless-sky/files/endless-sky-0.9.14-use-system-catch2.patch14
3 files changed, 41 insertions, 2 deletions
diff --git a/games-strategy/endless-sky/endless-sky-0.9.14.ebuild b/games-strategy/endless-sky/endless-sky-0.9.14.ebuild
index f0f7509aa8a8..0a6641ac67ee 100644
--- a/games-strategy/endless-sky/endless-sky-0.9.14.ebuild
+++ b/games-strategy/endless-sky/endless-sky-0.9.14.ebuild
@@ -13,6 +13,8 @@ SRC_URI="https://github.com/endless-sky/endless-sky/archive/v${PV}.tar.gz -> ${P
LICENSE="CC-BY-SA-4.0 CC-BY-SA-3.0 GPL-3+ public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
# Needs work; doesn't link against SDL 2
RESTRICT="test"
@@ -24,15 +26,18 @@ RDEPEND="media-libs/glew:0=
media-libs/libpng:=
media-libs/openal
virtual/opengl"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/catch:0 )"
PATCHES=(
"${FILESDIR}"/${PN}-0.9.14-respect-cflags.patch
"${FILESDIR}"/${PN}-0.9.14-no-games-path.patch
+ "${FILESDIR}"/${PN}-0.9.14-dont-compress-man-page.patch
+ "${FILESDIR}"/${PN}-0.9.14-use-system-catch2.patch
)
src_compile() {
- tc-export CXX
+ tc-export AR CXX
escons
}
diff --git a/games-strategy/endless-sky/files/endless-sky-0.9.14-dont-compress-man-page.patch b/games-strategy/endless-sky/files/endless-sky-0.9.14-dont-compress-man-page.patch
new file mode 100644
index 000000000000..d3836c088f31
--- /dev/null
+++ b/games-strategy/endless-sky/files/endless-sky-0.9.14-dont-compress-man-page.patch
@@ -0,0 +1,20 @@
+From 07f273e6f72a01158934158c3e8ff84c530367c9 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Thu, 6 Jan 2022 23:57:32 +0000
+Subject: [PATCH 2/2] Don't compress man page
+
+--- a/SConstruct
++++ b/SConstruct
+@@ -176,10 +176,9 @@ if env.get("PREFIX").startswith("/usr/"):
+ "gtk-update-icon-cache -t $DESTDIR$PREFIX/share/icons/hicolor/")
+
+ # Install the man page.
+-env.Command(
++env.Install(
+ "$DESTDIR$PREFIX/share/man/man6/endless-sky.6.gz",
+- "endless-sky.6",
+- "gzip -c $SOURCE > $TARGET")
++ "endless-sky.6")
+
+ # Install the data files.
+ def RecursiveInstall(env, target, source):
diff --git a/games-strategy/endless-sky/files/endless-sky-0.9.14-use-system-catch2.patch b/games-strategy/endless-sky/files/endless-sky-0.9.14-use-system-catch2.patch
new file mode 100644
index 000000000000..9b38e28a60fe
--- /dev/null
+++ b/games-strategy/endless-sky/files/endless-sky-0.9.14-use-system-catch2.patch
@@ -0,0 +1,14 @@
+From e8119dcdcb42479896a35cec5dc85c17c1901b2e Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Thu, 6 Jan 2022 23:56:59 +0000
+Subject: [PATCH 1/2] Use system copy of catch2
+
+In particular, we get glibc-2.34 fixes for free then.
+--- a/tests/include/es-test.hpp
++++ b/tests/include/es-test.hpp
+@@ -23,4 +23,4 @@ PARTICULAR PURPOSE. See the GNU General Public License for more details.
+ // #define CATCH_CONFIG_WINDOWS_CRTDBG
+ #endif
+
+-#include "catch.hpp"
++#include <catch2/catch.hpp>