summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-22 08:34:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-22 08:34:41 +0200
commit4955904c5f54a49a4e30a655c4b8c8f7edb1b43f (patch)
tree04647bed63a024f34d2002cbacd283faaa9a76fc /games-strategy
parentdev-python/hypothesis: Bump to 6.15.0 (diff)
downloadgentoo-4955904c5f54a49a4e30a655c4b8c8f7edb1b43f.tar.gz
gentoo-4955904c5f54a49a4e30a655c4b8c8f7edb1b43f.tar.bz2
gentoo-4955904c5f54a49a4e30a655c4b8c8f7edb1b43f.zip
games-strategy/colobot-data: Bump to 0.2.0-alpha
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/colobot-data/Manifest2
-rw-r--r--games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/games-strategy/colobot-data/Manifest b/games-strategy/colobot-data/Manifest
index 0a0a12154e1c..01f7000b9315 100644
--- a/games-strategy/colobot-data/Manifest
+++ b/games-strategy/colobot-data/Manifest
@@ -1,2 +1,4 @@
DIST colobot-gold-0.1.12-alpha.data.tar.gz 54732267 BLAKE2B 8cf36911764beb921e2b1009fd8550a1a146f594033cfc4de2d8587866780e22f060949735b03c2e355fab412c70c8557587f859edb86ca815ef249edc348926 SHA512 599cc72e1383826b5c840446f52f53b0f325b1de2ce08826bbd6b04072a51f1c4007b5683f2608dd7be67ab358ef2856e790bbbe5c73d8514141e3284be47508
+DIST colobot-gold-0.2.0-alpha.data.tar.gz 57792452 BLAKE2B 10cea12a220bb69db239e220a2ab4935177deea2c18181815b7a8dec9375c0f791f1fbabf7ac086bedb893e3a5b9543492635bf59cb3ab913ba4b3404bf273a5 SHA512 e36af1ad1e5470bec22a4923580be3ea5da69407b79af7c82a9d8c6ceff566b2f1e8e5aeb42f07098bbc459cc77ec391900ee79e8d0315a5abed7b36c44eafbb
DIST colobot-music_ogg_0.1.12-alpha.tar.gz 55596353 BLAKE2B 63be871fc2000c1cb041658b7395d5175cefc24c81661b366396965951efdadf1cf064211f3f543c4a4b1b7da5bd91db5e397844f1e8771318302c9d80788eb4 SHA512 486d084adc1b28a9fe36c530d261e48a89553c822989f493b0a92dabb9c3435953bda6fe98fcdabc72c6969b5e9be4ff9f3803066f6115fc7740c3de5d183764
+DIST colobot-music_ogg_0.2.0-alpha.tar.gz 55596353 BLAKE2B 63be871fc2000c1cb041658b7395d5175cefc24c81661b366396965951efdadf1cf064211f3f543c4a4b1b7da5bd91db5e397844f1e8771318302c9d80788eb4 SHA512 486d084adc1b28a9fe36c530d261e48a89553c822989f493b0a92dabb9c3435953bda6fe98fcdabc72c6969b5e9be4ff9f3803066f6115fc7740c3de5d183764
diff --git a/games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild b/games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild
new file mode 100644
index 000000000000..4800d0ed10c1
--- /dev/null
+++ b/games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake python-any-r1
+
+MY_PV=${PV/_/-}
+MY_P=colobot-gold-${MY_PV}
+MUSIC_P=colobot-music_ogg_${MY_PV}
+
+DESCRIPTION="Data package for colobot (Colonize with Bots)"
+HOMEPAGE="https://colobot.info/"
+SRC_URI="
+ https://github.com/colobot/colobot-data/archive/${MY_P}.tar.gz -> ${MY_P}.data.tar.gz
+ music? (
+ https://colobot.info/files/music/${MUSIC_P}.tar.gz )"
+S=${WORKDIR}/${PN}-${MY_P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+music"
+
+BDEPEND=${PYTHON_DEPS}
+
+src_unpack() {
+ unpack "${MY_P}.data.tar.gz"
+ if use music; then
+ tar -x -f "${DISTDIR}/${MUSIC_P}.tar.gz" -C "${S}/music" || die "Failed to unpack music"
+ fi
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use music; then
+ sed -i -e '/find_program(WGET wget)/d' -e '/if(NOT WGET)/,+2 d' music/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DMUSIC=$(usex music)
+ -DMUSIC_FLAC=OFF
+ )
+ cmake_src_configure
+}