summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-20 11:11:43 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-20 11:39:54 +0100
commit564930564aeb4bf901a4fcce413052584214e12a (patch)
treeb595594560ff538f6f8a7967daae052a4e8952c2 /games-strategy
parentapp-arch/stormlib: Add as a dep for games-strategy/wargus (diff)
downloadgentoo-564930564aeb4bf901a4fcce413052584214e12a.tar.gz
gentoo-564930564aeb4bf901a4fcce413052584214e12a.tar.bz2
gentoo-564930564aeb4bf901a4fcce413052584214e12a.zip
games-strategy/wargus: Support extracting BNE data
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wargus/metadata.xml4
-rw-r--r--games-strategy/wargus/wargus-3.0.0-r1.ebuild (renamed from games-strategy/wargus/wargus-3.0.0.ebuild)7
2 files changed, 8 insertions, 3 deletions
diff --git a/games-strategy/wargus/metadata.xml b/games-strategy/wargus/metadata.xml
index 4dbdbbfd0323..e87f6c4d810f 100644
--- a/games-strategy/wargus/metadata.xml
+++ b/games-strategy/wargus/metadata.xml
@@ -9,6 +9,10 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <use>
+ <flag name="bne">Support extracting data from the Battle.net
+ Edition</flag>
+ </use>
<upstream>
<remote-id type="github">Wargus/wargus</remote-id>
</upstream>
diff --git a/games-strategy/wargus/wargus-3.0.0.ebuild b/games-strategy/wargus/wargus-3.0.0-r1.ebuild
index 23954b3347a3..a15e86163b5b 100644
--- a/games-strategy/wargus/wargus-3.0.0.ebuild
+++ b/games-strategy/wargus/wargus-3.0.0-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/Wargus/wargus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="+bne"
RDEPEND="
=games-engines/stratagus-${PV}*[theora]
@@ -21,6 +21,7 @@ RDEPEND="
sys-libs/zlib:=
x11-libs/gtk+:2
x11-libs/libX11
+ bne? ( app-arch/stormlib:= )
!games-strategy/wargus-data"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -42,6 +43,7 @@ src_configure() {
-DSTRATAGUS="${EPREFIX}/usr/bin/stratagus"
-DSHAREDIR="${EPREFIX}/usr/share/stratagus/wargus"
-DICONDIR=/usr/share/icons/hicolor/64x64/apps
+ -DWITH_STORMLIB=$(usex bne)
)
cmake_src_configure
}
@@ -49,8 +51,7 @@ src_configure() {
pkg_postinst() {
elog "Wargus requires the data from the original game to run. The game"
elog "will ask you for the location of the game data and extract/convert"
- elog "it automatically on the first run. Only the DOS version is supported"
- elog "at the moment."
+ elog "it automatically on the first run."
if ! has_version media-video/ffmpeg ||
! has_version media-sound/cdparanoia