summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-01 10:21:46 +0000
committerSam James <sam@gentoo.org>2021-03-01 10:56:44 +0000
commit691c94e28f9a4f528294c001162b419e016955f6 (patch)
treeae3ee5c897ea22c86c80da719bd284e63e8d67e0 /games-strategy
parentnet-dialup/mgetty: add missing systemd unit (diff)
downloadgentoo-691c94e28f9a4f528294c001162b419e016955f6.tar.gz
gentoo-691c94e28f9a4f528294c001162b419e016955f6.tar.bz2
gentoo-691c94e28f9a4f528294c001162b419e016955f6.zip
games-strategy/0ad: add python-any-r1 for SpiderMonkey
Needed at buildtime for SpiderMonkey. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/0ad/0ad-0.0.24b_alpha.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/games-strategy/0ad/0ad-0.0.24b_alpha.ebuild b/games-strategy/0ad/0ad-0.0.24b_alpha.ebuild
index 3aa595b69b95..a36405f47449 100644
--- a/games-strategy/0ad/0ad-0.0.24b_alpha.ebuild
+++ b/games-strategy/0ad/0ad-0.0.24b_alpha.ebuild
@@ -4,8 +4,8 @@
EAPI=7
WX_GTK_VER="3.0-gtk3"
-
-inherit desktop toolchain-funcs multiprocessing wxwidgets xdg
+PYTHON_COMPAT=( python3_{7..9} )
+inherit desktop toolchain-funcs multiprocessing python-any-r1 wxwidgets xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -38,9 +38,11 @@ IUSE="editor +lobby nvtt pch test"
RESTRICT="test"
# virtual/rust is for bundled SpiderMonkey
+# Build-time Python dependency is for SM too
# TODO: Unbundle premake5
# See bug #773472 which may help (bump for it)
BDEPEND="
+ ${PYTHON_DEPS}
virtual/pkgconfig
virtual/rust
test? ( dev-lang/perl )