summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2020-11-15 19:30:31 +0300
committerSergey Popov <pinkbyte@gentoo.org>2020-11-15 19:33:26 +0300
commitc0281fe73e67f5ba86e7ae474b6a44002219e025 (patch)
treec91f95323c2476c47c33bc3efbf4703c15daf2b3 /games-strategy
parentnet-vpn/strongswan: bump to v5.9.1 (diff)
downloadgentoo-c0281fe73e67f5ba86e7ae474b6a44002219e025.tar.gz
gentoo-c0281fe73e67f5ba86e7ae474b6a44002219e025.tar.bz2
gentoo-c0281fe73e67f5ba86e7ae474b6a44002219e025.zip
games-strategy/seven-kingdoms: respect AR variable
Reported-by: Agostino Sarubbo <ago@gentoo.org> Closes: https://bugs.gentoo.org/740770 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/seven-kingdoms/seven-kingdoms-2.14.7.ebuild8
-rw-r--r--games-strategy/seven-kingdoms/seven-kingdoms-2.15.2.ebuild6
2 files changed, 11 insertions, 3 deletions
diff --git a/games-strategy/seven-kingdoms/seven-kingdoms-2.14.7.ebuild b/games-strategy/seven-kingdoms/seven-kingdoms-2.14.7.ebuild
index 33a7974f04b1..e76f54f62801 100644
--- a/games-strategy/seven-kingdoms/seven-kingdoms-2.14.7.ebuild
+++ b/games-strategy/seven-kingdoms/seven-kingdoms-2.14.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils
+inherit eutils toolchain-funcs
MY_PN="7kaa"
MY_P="${MY_PN}-${PV}"
@@ -29,6 +29,10 @@ src_unpack() {
unpack ${MY_P}.tar.xz
}
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_install() {
default
diff --git a/games-strategy/seven-kingdoms/seven-kingdoms-2.15.2.ebuild b/games-strategy/seven-kingdoms/seven-kingdoms-2.15.2.ebuild
index f8f2227e3f71..5e61bb4e116d 100644
--- a/games-strategy/seven-kingdoms/seven-kingdoms-2.15.2.ebuild
+++ b/games-strategy/seven-kingdoms/seven-kingdoms-2.15.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit desktop
+inherit desktop toolchain-funcs
MY_PN="7kaa"
MY_P="${MY_PN}-${PV}"
@@ -31,6 +31,10 @@ src_unpack() {
unpack ${MY_P}.tar.xz
}
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_install() {
default