summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-14 04:51:56 +0100
committerSam James <sam@gentoo.org>2021-08-14 04:53:02 +0100
commitc4325c2a30aef078b3adaef10146e631992fe556 (patch)
tree03cd013fa80c8248d31684affb8e9dd9d8c8de03 /games-strategy
parentnet-libs/nodejs: Stabilize 14.17.5-r1 amd64, #807775 (diff)
downloadgentoo-c4325c2a30aef078b3adaef10146e631992fe556.tar.gz
gentoo-c4325c2a30aef078b3adaef10146e631992fe556.tar.bz2
gentoo-c4325c2a30aef078b3adaef10146e631992fe556.zip
games-strategy/warzone2100: minor tidyups
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/warzone2100/warzone2100-4.1.3-r1.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/games-strategy/warzone2100/warzone2100-4.1.3-r1.ebuild b/games-strategy/warzone2100/warzone2100-4.1.3-r1.ebuild
index ef7e9bcae1d8..ab190710681b 100644
--- a/games-strategy/warzone2100/warzone2100-4.1.3-r1.ebuild
+++ b/games-strategy/warzone2100/warzone2100-4.1.3-r1.ebuild
@@ -17,12 +17,11 @@ S="${WORKDIR}/${PN}"
LICENSE="GPL-2+ CC-BY-SA-3.0 public-domain vulkan? ( GPL-3 )"
SLOT="0"
-#[[ "${PV}" == *_beta* ]] || \
KEYWORDS="~amd64 ~x86"
-# upstream requested debug support
+# Upstream requested debug support
IUSE="debug discord nls videos vulkan"
-# TODO: unbundle miniupnpc and quesoglc
+# TODO: unbundle miniupnpc and quesoglc, bug #477610
# quesoglc-0.7.2 is buggy: http://developer.wz2100.net/ticket/2828
CDEPEND="
>=dev-games/physfs-2[zip]
@@ -74,8 +73,8 @@ src_prepare() {
# Delete translations we're not using
cleanup_po() {
local locale=${1}
- einfo "Cleaning up disabled locale: ${1}"
- rm po/${1}.po || die
+ einfo "Cleaning up disabled locale: ${locale}"
+ rm po/${locale}.po || die
}
plocale_for_each_disabled_locale cleanup_po
@@ -86,12 +85,13 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DWZ_DISTRIBUTOR="Gentoo Linux"
- -DWZ_ENABLE_WARNINGS_AS_ERRORS="OFF"
- -DWZ_ENABLE_BACKEND_VULKAN="$(usex vulkan)"
- -DBUILD_SHARED_LIBS="OFF"
- -DENABLE_NLS="$(usex nls)"
- -DENABLE_DISCORD="$(usex discord)"
+ -DWZ_ENABLE_WARNINGS_AS_ERRORS=OFF
+ -DWZ_ENABLE_BACKEND_VULKAN=$(usex vulkan)
+ -DBUILD_SHARED_LIBS=OFF
+ -DENABLE_NLS=$(usex nls)
+ -DENABLE_DISCORD=$(usex discord)
)
+
cmake_src_configure
}