summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-10-06 13:58:06 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-10-06 14:12:04 -0400
commitccd85b73ed903bd8696a15ca83a70b6b114dc96d (patch)
treea70d122632f88fd162ecb6d4f873c12fe298666e /games-strategy
parentnet-dns/pdns-recursor: Version bump to 4.4.0_rc2 (diff)
downloadgentoo-ccd85b73ed903bd8696a15ca83a70b6b114dc96d.tar.gz
gentoo-ccd85b73ed903bd8696a15ca83a70b6b114dc96d.tar.bz2
gentoo-ccd85b73ed903bd8696a15ca83a70b6b114dc96d.zip
games-strategy/freeorion: Bump to 0.4.10.1
Closes: https://bugs.gentoo.org/show_bug.cgi?id=735768 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeorion/Manifest2
-rw-r--r--games-strategy/freeorion/freeorion-0.4.10.1.ebuild (renamed from games-strategy/freeorion/freeorion-0.4.9_p20200409-r1.ebuild)12
-rw-r--r--games-strategy/freeorion/freeorion-9999.ebuild12
3 files changed, 13 insertions, 13 deletions
diff --git a/games-strategy/freeorion/Manifest b/games-strategy/freeorion/Manifest
index a13368d9c419..4f0f36b38b3e 100644
--- a/games-strategy/freeorion/Manifest
+++ b/games-strategy/freeorion/Manifest
@@ -1 +1 @@
-DIST freeorion-0.4.9_p20200409.tar.gz 124663848 BLAKE2B 7468a386829498c9ca971e686bda216002b6f263fbc0f3784e7898854ad91278441579c1a3e0d1ef2d92b46747d14a17463e46d7ba16f06633e9a5d474ce3b9c SHA512 09fe8db818c3f22bac94577461d9ada082a2c8365cb524948bf13650ea368fcc55043f4df2f9701075011c890a08197e7f7bb13d8884cb41cc8e1346b8538345
+DIST freeorion-0.4.10.1.tar.gz 124693099 BLAKE2B d24c481e7be6f718897bb095209673f24cb7d43842f148cf1e8665254970d22449bf7a4ee4ba7a8cb3b5b515d6bed38a24e2862810959a63b29ba9d3c054e6c4 SHA512 b28a8bdc2428778480ff8404ad7d84153939f4f8b4a75f51775354e3e563f7f309d479e499ea1be8b57822d725cc57ece8dd14f2e40360ab6c07d70c917bc256
diff --git a/games-strategy/freeorion/freeorion-0.4.9_p20200409-r1.ebuild b/games-strategy/freeorion/freeorion-0.4.10.1.ebuild
index c1efcaa3e7c0..eaf03461b487 100644
--- a/games-strategy/freeorion/freeorion-0.4.9_p20200409-r1.ebuild
+++ b/games-strategy/freeorion/freeorion-0.4.10.1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils python-single-r1 xdg
+inherit cmake python-single-r1 xdg
DESCRIPTION="A free turn-based space empire and galactic conquest game"
HOMEPAGE="https://www.freeorion.org"
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]]; then
else
KEYWORDS="~amd64"
if [[ ${PV} = *_p* ]]; then
- COMMIT="1570afb475763b13f5d2f434037ec907da812bb4"
+ COMMIT=""
SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"
else
@@ -35,7 +35,7 @@ BDEPEND="
"
RDEPEND="
$(python_gen_cond_dep '
- >=dev-libs/boost-1.67:=[nls,python,threads,${PYTHON_MULTI_USEDEP}]
+ >=dev-libs/boost-1.58:=[nls,python,threads,${PYTHON_MULTI_USEDEP}]
')
!dedicated? (
media-libs/freealut
@@ -57,7 +57,7 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -e "s/-O3//" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake-src_prepare
}
src_configure() {
@@ -67,11 +67,11 @@ src_configure() {
-DBUILD_HEADLESS="$(usex dedicated)"
)
- cmake-utils_src_configure
+ cmake-src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newenvd "${FILESDIR}/${PN}.envd" 99${PN}
}
diff --git a/games-strategy/freeorion/freeorion-9999.ebuild b/games-strategy/freeorion/freeorion-9999.ebuild
index 048d1b8bf695..0b5fba26ee50 100644
--- a/games-strategy/freeorion/freeorion-9999.ebuild
+++ b/games-strategy/freeorion/freeorion-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils python-single-r1 xdg
+inherit cmake python-single-r1 xdg
DESCRIPTION="A free turn-based space empire and galactic conquest game"
HOMEPAGE="https://www.freeorion.org"
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]]; then
else
KEYWORDS="~amd64"
if [[ ${PV} = *_p* ]]; then
- COMMIT="1570afb475763b13f5d2f434037ec907da812bb4"
+ COMMIT=""
SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"
else
@@ -35,7 +35,7 @@ BDEPEND="
"
RDEPEND="
$(python_gen_cond_dep '
- >=dev-libs/boost-1.67:=[python,threads,${PYTHON_MULTI_USEDEP}]
+ >=dev-libs/boost-1.60:=[nls,python,threads,${PYTHON_MULTI_USEDEP}]
')
!dedicated? (
media-libs/freealut
@@ -57,7 +57,7 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -e "s/-O3//" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -67,11 +67,11 @@ src_configure() {
-DBUILD_HEADLESS="$(usex dedicated)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newenvd "${FILESDIR}/${PN}.envd" 99${PN}
}