summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-23 12:16:30 +0000
committerMarek Szuba <marecki@gentoo.org>2020-12-23 14:52:00 +0000
commitd82c3cfbf857635eb7140cd0b4d191e8531b3c74 (patch)
treeafe62a2b484be2d9dec50c1e273622674ee9e895 /games-strategy
parentdev-libs/gmp: stable 6.2.1 for hppa, bug #760615 (diff)
downloadgentoo-d82c3cfbf857635eb7140cd0b4d191e8531b3c74.tar.gz
gentoo-d82c3cfbf857635eb7140cd0b4d191e8531b3c74.tar.bz2
gentoo-d82c3cfbf857635eb7140cd0b4d191e8531b3c74.zip
games-strategy/megaglest-data: bump to EAPI-7
Part of the migration of the game itself to lua-single.eclass. Note that since the files are now installed into /usr/share rather than /usr/games as per the current policy regarding game install locations and ownership, mixing EAPI-5 and EAPI-7 Megaglest ebuilds will badly break things. Bug: https://bugs.gentoo.org/752717 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/megaglest-data/megaglest-data-3.11.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/games-strategy/megaglest-data/megaglest-data-3.11.1-r1.ebuild b/games-strategy/megaglest-data/megaglest-data-3.11.1-r1.ebuild
new file mode 100644
index 000000000000..152c98954194
--- /dev/null
+++ b/games-strategy/megaglest-data/megaglest-data-3.11.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="megaglest"
+DESCRIPTION="Data files for the cross-platform 3D realtime strategy game MegaGlest"
+HOMEPAGE="http://www.megaglest.org/"
+SRC_URI="https://github.com/MegaGlest/megaglest-data/releases/download/${PV}/megaglest-data-${PV}.tar.xz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DOCS=( docs/AUTHORS.data.txt docs/CHANGELOG.txt docs/README.txt )
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ use doc && HTML_DOCS+=( docs/glest_factions/ )
+ cmake_src_install
+}