summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-14 13:51:19 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-14 13:51:19 +0100
commited468028e725c9580a7b2ee02d6b7b9375f7a0b2 (patch)
tree3a39616d9a763db526cec9d2562da20ec1c456a8 /games-strategy
parentsci-mathematics/form: bump to 4.3.0 (diff)
downloadgentoo-ed468028e725c9580a7b2ee02d6b7b9375f7a0b2.tar.gz
gentoo-ed468028e725c9580a7b2ee02d6b7b9375f7a0b2.tar.bz2
gentoo-ed468028e725c9580a7b2ee02d6b7b9375f7a0b2.zip
*/*: remove py3.8 from PYTHON_COMPAT
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/colobot-data/colobot-data-0.1.12.ebuild4
-rw-r--r--games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild4
-rw-r--r--games-strategy/endless-sky/endless-sky-0.9.14.ebuild4
-rw-r--r--games-strategy/freeorion/freeorion-0.4.10.2-r1.ebuild4
-rw-r--r--games-strategy/freeorion/freeorion-9999.ebuild4
-rw-r--r--games-strategy/naev/naev-0.10.1.ebuild4
-rw-r--r--games-strategy/naev/naev-0.10.2.ebuild2
-rw-r--r--games-strategy/widelands/widelands-1.1.ebuild4
-rw-r--r--games-strategy/widelands/widelands-9999.ebuild4
9 files changed, 17 insertions, 17 deletions
diff --git a/games-strategy/colobot-data/colobot-data-0.1.12.ebuild b/games-strategy/colobot-data/colobot-data-0.1.12.ebuild
index d63d0f6787bd..cf7dc01d2adf 100644
--- a/games-strategy/colobot-data/colobot-data-0.1.12.ebuild
+++ b/games-strategy/colobot-data/colobot-data-0.1.12.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_9 )
inherit cmake python-any-r1
MY_P=colobot-gold-${PV}-alpha
diff --git a/games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild b/games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild
index 76d688ad08ea..652cdf64b603 100644
--- a/games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild
+++ b/games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit cmake python-any-r1
MY_PV=${PV/_/-}
diff --git a/games-strategy/endless-sky/endless-sky-0.9.14.ebuild b/games-strategy/endless-sky/endless-sky-0.9.14.ebuild
index 0a6641ac67ee..8a815e3b53e5 100644
--- a/games-strategy/endless-sky/endless-sky-0.9.14.ebuild
+++ b/games-strategy/endless-sky/endless-sky-0.9.14.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{9,10} )
inherit python-any-r1 scons-utils toolchain-funcs xdg
DESCRIPTION="Space exploration, trading & combat in the tradition of Terminal Velocity"
diff --git a/games-strategy/freeorion/freeorion-0.4.10.2-r1.ebuild b/games-strategy/freeorion/freeorion-0.4.10.2-r1.ebuild
index 3d3075568e67..6744b4443595 100644
--- a/games-strategy/freeorion/freeorion-0.4.10.2-r1.ebuild
+++ b/games-strategy/freeorion/freeorion-0.4.10.2-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# note: py3.11 is known failing at runtime with this version
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit check-reqs cmake multiprocessing python-single-r1 xdg
if [[ ${PV} == 9999 ]]; then
diff --git a/games-strategy/freeorion/freeorion-9999.ebuild b/games-strategy/freeorion/freeorion-9999.ebuild
index d725cfe38806..d95c1dfd5b18 100644
--- a/games-strategy/freeorion/freeorion-9999.ebuild
+++ b/games-strategy/freeorion/freeorion-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit check-reqs cmake multiprocessing python-single-r1 xdg
if [[ ${PV} == 9999 ]]; then
diff --git a/games-strategy/naev/naev-0.10.1.ebuild b/games-strategy/naev/naev-0.10.1.ebuild
index a7a76f796caf..c67ccc0ead92 100644
--- a/games-strategy/naev/naev-0.10.1.ebuild
+++ b/games-strategy/naev/naev-0.10.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
LUA_COMPAT=( lua5-1 luajit )
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit lua-single meson python-any-r1 virtualx xdg
DESCRIPTION="2D space trading and combat game, in a similar vein to Escape Velocity"
diff --git a/games-strategy/naev/naev-0.10.2.ebuild b/games-strategy/naev/naev-0.10.2.ebuild
index f66552cc380e..cbc36cb869ca 100644
--- a/games-strategy/naev/naev-0.10.2.ebuild
+++ b/games-strategy/naev/naev-0.10.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
LUA_COMPAT=( lua5-1 luajit )
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit lua-single meson python-any-r1 virtualx xdg
DESCRIPTION="2D space trading and combat game, in a similar vein to Escape Velocity"
diff --git a/games-strategy/widelands/widelands-1.1.ebuild b/games-strategy/widelands/widelands-1.1.ebuild
index 8d19ee6f56bb..694f1e6b01d3 100644
--- a/games-strategy/widelands/widelands-1.1.ebuild
+++ b/games-strategy/widelands/widelands-1.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit cmake python-any-r1 xdg
if [[ ${PV} == 9999 ]]; then
diff --git a/games-strategy/widelands/widelands-9999.ebuild b/games-strategy/widelands/widelands-9999.ebuild
index 8d19ee6f56bb..694f1e6b01d3 100644
--- a/games-strategy/widelands/widelands-9999.ebuild
+++ b/games-strategy/widelands/widelands-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit cmake python-any-r1 xdg
if [[ ${PV} == 9999 ]]; then