summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-06-29 17:54:02 -0500
committerAustin English <wizardedit@gentoo.org>2016-06-29 17:54:17 -0500
commit4149932ec6fff6292f0431277d4b0273dd51ebd7 (patch)
tree8f13dad3db7d5e33de11e28670ba404b07aa38ee /games-util/gslist/gslist-0.8.11a-r1.ebuild
parentgames-util/mcrcon: remove depreacted games eclass (diff)
downloadgentoo-4149932ec6fff6292f0431277d4b0273dd51ebd7.tar.gz
gentoo-4149932ec6fff6292f0431277d4b0273dd51ebd7.tar.bz2
gentoo-4149932ec6fff6292f0431277d4b0273dd51ebd7.zip
games-util/gslist: remove depreacted games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.2.28
Diffstat (limited to 'games-util/gslist/gslist-0.8.11a-r1.ebuild')
-rw-r--r--games-util/gslist/gslist-0.8.11a-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-util/gslist/gslist-0.8.11a-r1.ebuild b/games-util/gslist/gslist-0.8.11a-r1.ebuild
new file mode 100644
index 000000000000..b497ce23f146
--- /dev/null
+++ b/games-util/gslist/gslist-0.8.11a-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A GameSpy server browser"
+HOMEPAGE="http://aluigi.altervista.org/papers.htm#gslist"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="web"
+
+RDEPEND="dev-libs/geoip"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+)
+
+src_prepare() {
+ default
+ rm -f gslist gslistsql *.exe *.dll || die
+}
+
+src_compile() {
+ emake SQL=0 $(use web || echo GSWEB=0)
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ${PN}.txt
+}