summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/higan-purify
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/higan-purify')
-rw-r--r--games-util/higan-purify/Manifest1
-rw-r--r--games-util/higan-purify/files/higan-purify-03-QA.patch42
-rw-r--r--games-util/higan-purify/higan-purify-03.ebuild67
-rw-r--r--games-util/higan-purify/metadata.xml6
4 files changed, 116 insertions, 0 deletions
diff --git a/games-util/higan-purify/Manifest b/games-util/higan-purify/Manifest
new file mode 100644
index 000000000000..6b6c362cb405
--- /dev/null
+++ b/games-util/higan-purify/Manifest
@@ -0,0 +1 @@
+DIST purify_v03-source.tar.xz 196924 SHA256 2020f0b5a744f08c24085a15a6c2ec1d7c4424bba6727f244e513b95c4247e38 SHA512 095b62013f5a33e720b87c48f32c41239d8cef4c6ddc2b6d119d15b3f8b92bc15d744afa0b2bc8d7a49ef53f8f3fa7f2247be490499a9b194863534f9c1a4b3d WHIRLPOOL 395c6976d19065c23f084aa452286b81db8068ae46a658172b749f3ef2ee879514c1c64ee2e8ac8b1eaa4ed16ebaa540852b355c0ae42855759d9d3337e185ae
diff --git a/games-util/higan-purify/files/higan-purify-03-QA.patch b/games-util/higan-purify/files/higan-purify-03-QA.patch
new file mode 100644
index 000000000000..e523ba4cad95
--- /dev/null
+++ b/games-util/higan-purify/files/higan-purify-03-QA.patch
@@ -0,0 +1,42 @@
+--- purify_v03-source/purify/Makefile
++++ purify_v03-source/purify/Makefile
+@@ -2,8 +2,8 @@
+ include phoenix/Makefile
+
+ path := /usr/local/bin
+-flags := -I. -O3 -fomit-frame-pointer
+-link := -s
++flags := -I. $(CXXFLAGS)
++link := $(LDFLAGS)
+ objects := obj/phoenix.o obj/purify.o
+
+ ifeq ($(platform),x)
+@@ -22,7 +22,7 @@
+
+ build: $(objects)
+ ifeq ($(platform),x)
+- $(cpp) -pthread $(link) -o purify $(objects) $(phoenixlink)
++ $(cpp) $(flags) -pthread $(link) -o purify $(objects) $(phoenixlink)
+ else ifeq ($(platform),win)
+ windres phoenix/windows/phoenix.rc obj/phoenix-resource.o
+ $(cpp) -shared -o phoenix.dll obj/phoenix.o $(phoenixlink)
+--- purify_v03-source/purify/phoenix/Makefile
++++ purify_v03-source/purify/phoenix/Makefile
+@@ -4,13 +4,13 @@
+ endif
+
+ ifeq ($(phoenix),gtk)
+- phoenixflags := -DPHOENIX_GTK `pkg-config --cflags gtk+-2.0`
+- phoenixlink := `pkg-config --libs gtk+-2.0`
++ phoenixflags := -DPHOENIX_GTK `pkg-config --cflags gtk+-2.0 x11`
++ phoenixlink := `pkg-config --libs gtk+-2.0 x11` -ldl
+ endif
+
+ ifeq ($(phoenix),qt)
+- phoenixflags := -DPHOENIX_QT `pkg-config --cflags QtCore QtGui`
+- phoenixlink := `pkg-config --libs QtCore QtGui`
++ phoenixflags := -DPHOENIX_QT `pkg-config --cflags QtCore QtGui x11`
++ phoenixlink := `pkg-config --libs QtCore QtGui x11` -ldl
+ endif
+ else ifeq ($(platform),win)
+ phoenixflags := -DPHOENIX_WINDOWS
diff --git a/games-util/higan-purify/higan-purify-03.ebuild b/games-util/higan-purify/higan-purify-03.ebuild
new file mode 100644
index 000000000000..d27b1956f1e1
--- /dev/null
+++ b/games-util/higan-purify/higan-purify-03.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs qmake-utils
+
+MY_P=purify_v${PV}-source
+
+DESCRIPTION="Rom purifier for higan"
+HOMEPAGE="http://byuu.org/higan/"
+SRC_URI="http://higan.googlecode.com/files/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="qt4"
+
+RDEPEND="
+ dev-games/higan-ananke
+ x11-libs/libX11
+ !qt4? ( x11-libs/gtk+:2 )
+ qt4? ( >=dev-qt/qtgui-4.5:4 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}/purify
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 7 || $(gcc-major-version) -lt 4 ]] ; then
+ eerror "You need at least sys-devel/gcc-4.7.0"
+ die "You need at least sys-devel/gcc-4.7.0"
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-QA.patch
+ sed -i \
+ -e "/handle/s#/usr/local/lib#/usr/$(get_libdir)#" \
+ nall/dl.hpp || die
+
+ # regenerate .moc if needed
+ if use qt4; then
+ cd phoenix/qt || die
+ "$(qt4_get_bindir)"/moc -i -I. -o platform.moc platform.moc.hpp || die
+ fi
+}
+
+src_compile() {
+ if use qt4; then
+ mytoolkit="qt"
+ else
+ mytoolkit="gtk"
+ fi
+
+ emake \
+ platform="x" \
+ compiler="$(tc-getCXX)" \
+ phoenix="${mytoolkit}"
+}
+
+src_install() {
+ dobin purify
+}
diff --git a/games-util/higan-purify/metadata.xml b/games-util/higan-purify/metadata.xml
new file mode 100644
index 000000000000..01a746edb196
--- /dev/null
+++ b/games-util/higan-purify/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>
+