summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-10-14 15:53:24 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-10-14 15:59:44 +0200
commit21dc3dc5b911b91988d1eceb92908e69959136c6 (patch)
treef9ae3aa19329d78f24c023b3d61815eb217905fa /games-util/joystick/joystick-1.7.0.ebuild
parentgames-strategy/hedgewars: Bump to version 1.0.0 (diff)
downloadgentoo-21dc3dc5b911b91988d1eceb92908e69959136c6.tar.gz
gentoo-21dc3dc5b911b91988d1eceb92908e69959136c6.tar.bz2
gentoo-21dc3dc5b911b91988d1eceb92908e69959136c6.zip
games-util/joystick: Bump to version 1.7.0
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-util/joystick/joystick-1.7.0.ebuild')
-rw-r--r--games-util/joystick/joystick-1.7.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-util/joystick/joystick-1.7.0.ebuild b/games-util/joystick/joystick-1.7.0.ebuild
new file mode 100644
index 000000000000..a4389f20bcfb
--- /dev/null
+++ b/games-util/joystick/joystick-1.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="https://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="sdl udev"
+
+DEPEND="sdl? ( media-libs/libsdl2:0[video] )
+ !<x11-libs/tslib-1.0-r2"
+RDEPEND="${DEPEND}
+ udev? ( virtual/udev )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-build.patch
+)
+
+src_prepare() {
+ default
+
+ export PREFIX=/usr
+ tc-export CC PKG_CONFIG
+ export USE_SDL=$(usex sdl)
+}
+
+src_install() {
+ default
+ if ! use udev ; then
+ rm "${ED}"/usr/bin/jscal-{re,}store || die
+ fi
+}