summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-04-30 22:59:30 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-04-30 22:59:30 +0100
commita5b485633c0e12a96f1fd60edee7e812777ce936 (patch)
treefa67ce4f33210d4b918adad555dd38aa63b75303 /games-util/lgogdownloader/lgogdownloader-3.5.ebuild
parentmedia-video/makemkv: Add LibreSSL support (diff)
downloadgentoo-a5b485633c0e12a96f1fd60edee7e812777ce936.tar.gz
gentoo-a5b485633c0e12a96f1fd60edee7e812777ce936.tar.bz2
gentoo-a5b485633c0e12a96f1fd60edee7e812777ce936.zip
games-util/lgogdownloader: Version bump to 3.5
Adds GUI login support for passing reCAPTCHA. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util/lgogdownloader/lgogdownloader-3.5.ebuild')
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-util/lgogdownloader/lgogdownloader-3.5.ebuild b/games-util/lgogdownloader/lgogdownloader-3.5.ebuild
new file mode 100644
index 000000000000..0f8ac4e4d85d
--- /dev/null
+++ b/games-util/lgogdownloader/lgogdownloader-3.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Unofficial GOG.com downloader for Linux"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+SRC_URI="https://sites.google.com/site/gogdownloader/${P}.tar.gz"
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
+ dev-cpp/htmlcxx:0=
+ dev-libs/boost:0=
+ >=dev-libs/jsoncpp-1.7:0=
+ dev-libs/tinyxml2:0=
+ net-libs/liboauth:0=
+ >=net-misc/curl-7.32:0=[ssl]
+ gui? ( dev-qt/qtwebengine:5=[widgets] )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="sys-apps/help2man
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_GUI=$(usex gui)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}