summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-10 02:58:46 +0100
committerSam James <sam@gentoo.org>2021-08-10 02:59:35 +0100
commit765827fea568960a8a4e3a0761ef153b1c022ded (patch)
tree8cb235ac763a919b91f4ce63c8ddcaf71ea4c296 /games-util/lutris
parentpackage.mask: remove last-rited media-plugins/kodi-vfs-sacd (diff)
downloadgentoo-765827fea568960a8a4e3a0761ef153b1c022ded.tar.gz
gentoo-765827fea568960a8a4e3a0761ef153b1c022ded.tar.bz2
gentoo-765827fea568960a8a4e3a0761ef153b1c022ded.zip
games-util/lutris: add 0.5.8.4
Still fails some tests but looks like there's progress upstream and the patches are rather large. Closes: https://bugs.gentoo.org/803236 Bug: https://bugs.gentoo.org/770880 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-util/lutris')
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/lutris-0.5.8.4.ebuild77
-rw-r--r--games-util/lutris/lutris-9999.ebuild7
3 files changed, 80 insertions, 5 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index 34940b5f0807..f4bd553bb1c3 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,2 +1,3 @@
DIST lutris_0.5.8.1.tar.xz 893328 BLAKE2B 67c66b59c3fa78af46f953b6e27fb3dd77d0e4cb0746f490716c7c074e81afa4f9c4e8c10dc6d4dab3e2b37d03254bae5eda0b777da72bc17f18dda5fd1f990a SHA512 da3b5ebf3e5dcc5011351197c5a80e8547e54df4555ea9124a8404877c5b75225cfae970819a171c55454fef73afdd927dafbf427301b71618c33660a1c8c022
DIST lutris_0.5.8.3.tar.xz 942716 BLAKE2B f831c6ad6f67c3948f07e89f9caacd0d8aa3878b912fe987afea85eea549f41347044967255fa80e4e0c4544d148d9782dfe3c5bf08a123436e8a5ef7034901f SHA512 8f653d38a9a551298fa344cde67d53bf50cfd2a0a0667e344d04f6e17dda4ef358037755975d1a7f74ecd39824d58f9586e8a82b70dccc26619f22fee94d1144
+DIST lutris_0.5.8.4.tar.xz 957004 BLAKE2B f3acce5d9ea7368063a3135c1f503e0644c1cbc7676e966c262c8e04c5e0d23b4882793fe2df1beab265ab4128e8a90b5bb69401f8e567b0cceeea3008ff4fa7 SHA512 f79a9fd06788bc28e59ad6d2c403b83f8bdeaee0116ae7fbf765e80e4e08bf760a462c71f75a2ff46739e5757cb8609f5110a51d83266d3aba2f0c91524b6df9
diff --git a/games-util/lutris/lutris-0.5.8.4.ebuild b/games-util/lutris/lutris-0.5.8.4.ebuild
new file mode 100644
index 000000000000..b29f07d71d87
--- /dev/null
+++ b/games-util/lutris/lutris-0.5.8.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+DISTUTILS_SINGLE_IMPL="1"
+
+inherit distutils-r1 virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
+ inherit git-r3
+else
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gnome-desktop:3[introspection]
+ media-sound/fluid-soundfont
+ net-libs/libsoup
+ net-libs/webkit-gtk:4[introspection]
+ x11-apps/mesa-progs
+ x11-apps/xgamma
+ x11-apps/xrandr
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+"
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst docs/installers.rst )
+ distutils-r1_python_install_all
+ python_fix_shebang "${ED}"/usr/share/lutris/bin/lutris-wrapper #740048
+}
+
+python_test() {
+ virtx nosetests -v
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Quote README.rst
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
+}
diff --git a/games-util/lutris/lutris-9999.ebuild b/games-util/lutris/lutris-9999.ebuild
index da0698d5ca9e..b29f07d71d87 100644
--- a/games-util/lutris/lutris-9999.ebuild
+++ b/games-util/lutris/lutris-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..9} )
PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL="1"
@@ -23,7 +23,6 @@ fi
LICENSE="GPL-3"
SLOT="0"
-
RESTRICT="!test? ( test )"
BDEPEND="
@@ -39,7 +38,6 @@ RDEPEND="
app-arch/unzip
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/python-evdev[${PYTHON_USEDEP}]
@@ -54,9 +52,8 @@ RDEPEND="
x11-apps/mesa-progs
x11-apps/xgamma
x11-apps/xrandr
- x11-libs/libnotify[introspection]
x11-libs/gtk+:3[introspection]
- x11-libs/gdk-pixbuf[jpeg]
+ x11-libs/libnotify[introspection]
"
python_install_all() {