summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-11 18:10:47 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-11 18:11:22 -0500
commitfa5cc11feefd6de4503a81714e0dce64f4041a49 (patch)
tree6f15f9c9fb54b197d3867315f06d7cf88f3f54a7 /games-util/nml/nml-0.4.2-r1.ebuild
parentdev-java/jacoco: Initial import. (diff)
downloadgentoo-fa5cc11feefd6de4503a81714e0dce64f4041a49.tar.gz
gentoo-fa5cc11feefd6de4503a81714e0dce64f4041a49.tar.bz2
gentoo-fa5cc11feefd6de4503a81714e0dce64f4041a49.zip
rev bump to push out the patch (bug #563906)
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-util/nml/nml-0.4.2-r1.ebuild')
-rw-r--r--games-util/nml/nml-0.4.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-util/nml/nml-0.4.2-r1.ebuild b/games-util/nml/nml-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..8ccbac26f515
--- /dev/null
+++ b/games-util/nml/nml-0.4.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into grf/nfo files"
+HOMEPAGE="http://dev.openttdcoop.org/projects/nml"
+SRC_URI="http://bundles.openttdcoop.org/nml/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="dev-python/pillow[zlib,${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/{changelog,readme}.txt )
+PATCHES=( "${FILESDIR}"/${P}-pillow3.patch )
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/nmlc.1
+}