summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-04-18 22:32:35 +0200
committerJames Le Cuirot <chewi@gentoo.org>2019-04-18 22:36:24 +0100
commit1969f40f80d6e01ece691d69403762d4a6de3963 (patch)
treea1807e9f9d12d4c7be30d2c9d44070378464755f /games-util/nml/nml-0.4.5-r1.ebuild
parentwww-client/chromium: Backport XDG_CURRENT_DESKTOP parsing fix (diff)
downloadgentoo-1969f40f80d6e01ece691d69403762d4a6de3963.tar.gz
gentoo-1969f40f80d6e01ece691d69403762d4a6de3963.tar.bz2
gentoo-1969f40f80d6e01ece691d69403762d4a6de3963.zip
games-util/nml: add patch for >=dev-python/pillow-6.0.0
Patch submitted upstream: https://github.com/OpenTTD/nml/pull/29 Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/11734 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util/nml/nml-0.4.5-r1.ebuild')
-rw-r--r--games-util/nml/nml-0.4.5-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-util/nml/nml-0.4.5-r1.ebuild b/games-util/nml/nml-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..6f8e7f6ea8da
--- /dev/null
+++ b/games-util/nml/nml-0.4.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into grf/nfo files"
+HOMEPAGE="https://dev.openttdcoop.org/projects/nml"
+SRC_URI="http://bundles.openttdcoop.org/nml/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="dev-python/pillow[zlib,${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/{changelog,readme}.txt )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.4-pillow3.patch
+ "${FILESDIR}"/${PN}-0.4.5-pillow6.patch
+)
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/nmlc.1
+}