summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-18 11:57:14 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-18 11:57:14 +0200
commit69e63ee0a58f487d14050e2ed6900502fb38b742 (patch)
tree783e319a5c89aad0ed02690511a4f21cc51d5d28 /games-util/qstat/qstat-2.14.ebuild
parentgames-util/catcodec: Bump to version 1.0.5 (diff)
downloadgentoo-69e63ee0a58f487d14050e2ed6900502fb38b742.tar.gz
gentoo-69e63ee0a58f487d14050e2ed6900502fb38b742.tar.bz2
gentoo-69e63ee0a58f487d14050e2ed6900502fb38b742.zip
games-util/qstat: Bump to version 2.14
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'games-util/qstat/qstat-2.14.ebuild')
-rw-r--r--games-util/qstat/qstat-2.14.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-util/qstat/qstat-2.14.ebuild b/games-util/qstat/qstat-2.14.ebuild
new file mode 100644
index 000000000000..75834f2b6f6a
--- /dev/null
+++ b/games-util/qstat/qstat-2.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Server statics collector supporting many FPS games"
+HOMEPAGE="https://github.com/multiplay/qstat"
+SRC_URI="https://github.com/multiplay/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+DEPEND="!sys-cluster/torque"
+
+DOCS=( CHANGES.txt COMPILE.txt template/README.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+
+ # bug #530952
+ sed -i -e 's/strndup/l_strndup/g' qstat.c || die
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ default
+ dosym qstat /usr/bin/quakestat
+ dohtml template/*.html qstatdoc.html
+}