summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-04-05 22:05:28 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-04-05 22:05:28 +0100
commita7e669bf179acfd1aa8984449c91809d842787d2 (patch)
tree8deaa59ac2794b10d73756c29d3db40b874a8b91 /games-util/umodpack/umodpack-0.5_beta16-r2.ebuild
parentapp-portage/nattka: Enable docs (diff)
downloadgentoo-a7e669bf179acfd1aa8984449c91809d842787d2.tar.gz
gentoo-a7e669bf179acfd1aa8984449c91809d842787d2.tar.bz2
gentoo-a7e669bf179acfd1aa8984449c91809d842787d2.zip
games-util/umodpack: Fixes for new Perl, drop broken GUI, EAPI 7
Closes: https://bugs.gentoo.org/716196 Package-Manager: Portage-2.3.96, Repoman-2.3.20 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util/umodpack/umodpack-0.5_beta16-r2.ebuild')
-rw-r--r--games-util/umodpack/umodpack-0.5_beta16-r2.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild b/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild
deleted file mode 100644
index 772fe6487292..000000000000
--- a/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit perl-module toolchain-funcs
-
-MY_P=${P/_beta/b}
-DESCRIPTION="portable and useful [un]packer for Unreal Tournament's Umod files"
-HOMEPAGE="http://www.oldunreal.com/wiki/index.php?title=UmodPack"
-SRC_URI="mirror://gentoo/${MY_P}-allinone.tar.gz"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="tk"
-
-DEPEND="virtual/perl-IO-Compress
- dev-perl/Archive-Zip
- dev-perl/Tie-IxHash
- tk? ( dev-perl/Tk )"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${MY_P}
-SRC_TEST="do parallel"
-
-src_prepare() {
- # remove the stupid perl modules since we already installed em
- rm -rf {Archive-Zip,Compress-Zlib,Tie-IxHash,Tk}* || die
-}
-
-src_compile() {
- perl-module_src_compile
-
- cd umr-0.3 || die
- emake DEBUG=0 CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
-}
-
-src_install() {
- mydoc="Changes"
- perl-module_src_install
- dobin umod umr-0.3/umr
- if use tk ; then
- dobin xumod
- fi
-}