summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-07-02 16:33:32 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-07-02 16:35:10 +0100
commit1a467e8b2506662594afc28732a9249e8686c10e (patch)
treee83b2fc386545cbcac166176f84cc82fd4a7623a /games-util/xboxdrv/xboxdrv-0.8.8.ebuild
parentdev-python/stormpath: remove version 2.1.5 (diff)
downloadgentoo-1a467e8b2506662594afc28732a9249e8686c10e.tar.gz
gentoo-1a467e8b2506662594afc28732a9249e8686c10e.tar.bz2
gentoo-1a467e8b2506662594afc28732a9249e8686c10e.zip
games-util/xboxdrv: Version bump to 0.8.8, EAPI bump to 6, bug #567182
Includes patch to fix 60 second delay, upstream GitHub issue #144. Package-Manager: portage-2.3.0
Diffstat (limited to 'games-util/xboxdrv/xboxdrv-0.8.8.ebuild')
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.8.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/games-util/xboxdrv/xboxdrv-0.8.8.ebuild b/games-util/xboxdrv/xboxdrv-0.8.8.ebuild
new file mode 100644
index 000000000000..04d3c7d0782b
--- /dev/null
+++ b/games-util/xboxdrv/xboxdrv-0.8.8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit linux-info scons-utils toolchain-funcs systemd udev
+
+MY_P=${PN}-linux-${PV}
+DESCRIPTION="Userspace Xbox 360 Controller driver"
+HOMEPAGE="http://pingus.seul.org/~grumbel/xboxdrv/"
+SRC_URI="http://pingus.seul.org/~grumbel/xboxdrv/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/boost:=
+ dev-libs/dbus-glib:=
+ virtual/libudev:=
+ sys-apps/dbus:=
+ dev-libs/glib:2=
+ virtual/libusb:1=
+ x11-libs/libX11:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-scons.patch
+ "${FILESDIR}"/github-144.patch
+)
+
+CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"
+
+src_compile() {
+ escons \
+ BUILD=custom \
+ CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ CXXFLAGS="-Wall ${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xboxdrv
+ doman doc/xboxdrv.1
+ dodoc AUTHORS NEWS PROTOCOL README.md TODO
+
+ newinitd "${FILESDIR}"/xboxdrv.initd xboxdrv
+ newconfd "${FILESDIR}"/xboxdrv.confd xboxdrv
+
+ insinto /etc/dbus-1/system.d/
+ doins "${FILESDIR}/org.seul.Xboxdrv.conf"
+
+ udev_newrules "${FILESDIR}"/xboxdrv.udev-rules 99-xbox-controller.rules
+ systemd_dounit "${FILESDIR}"/xboxdrv.service
+}
+
+pkg_postinst() {
+ udev_reload
+}