summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-01-18 21:59:38 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-01-18 21:59:38 +0000
commit900515f23f4d28575159f549334121ec3bde2bb8 (patch)
treef7b2b2249f7d85d3cc89e125b8f97ce96e5f56c7 /games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild
parentdev-python/mysqlclient: 1.4.0 bump (diff)
downloadgentoo-900515f23f4d28575159f549334121ec3bde2bb8.tar.gz
gentoo-900515f23f4d28575159f549334121ec3bde2bb8.tar.bz2
gentoo-900515f23f4d28575159f549334121ec3bde2bb8.zip
games-util/xboxdrv: Bump to fix SCons under Python 2
I didn't realise that the patch to fix Python 3 had broken 2. Closes: https://bugs.gentoo.org/675766 Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild')
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild b/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild
new file mode 100644
index 000000000000..e72f053eabff
--- /dev/null
+++ b/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+
+inherit linux-info python-any-r1 scons-utils toolchain-funcs systemd udev
+
+COMMIT="6e5e8a57628095d8d0c8bbb38187afb0f3a42112"
+DESCRIPTION="Userspace Xbox 360 Controller driver"
+HOMEPAGE="https://xboxdrv.gitlab.io"
+SRC_URI="https://github.com/chewi/xboxdrv/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ sys-apps/dbus
+ virtual/libudev:=
+ virtual/libusb:1
+ x11-libs/libX11
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"
+
+src_prepare() {
+ default
+
+ # Make it clearer that this is a patched fork.
+ echo -n "${PV%_*}.${PV#*_p}-gentoo" > VERSION || die
+}
+
+src_compile() {
+ escons \
+ BUILD=custom \
+ CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ CXXFLAGS="-Wall ${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xboxdrv
+ doman doc/xboxdrv.1
+ dodoc AUTHORS NEWS PROTOCOL README.md TODO
+
+ newinitd "${FILESDIR}"/xboxdrv.initd xboxdrv
+ newconfd "${FILESDIR}"/xboxdrv.confd xboxdrv
+
+ insinto /etc/dbus-1/system.d
+ doins "${FILESDIR}"/org.seul.Xboxdrv.conf
+
+ udev_newrules "${FILESDIR}"/xboxdrv.udev-rules 99-xbox-controller.rules
+ systemd_dounit "${FILESDIR}"/xboxdrv.service
+}
+
+pkg_postinst() {
+ udev_reload
+}