summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-08 20:36:25 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-08 20:36:43 +0200
commit0cd8f10f2c32a738f8828b6a7417d43895051cec (patch)
tree386a6ad3b71ce78bbef40144a3259cbfc02a5ee4 /games-util
parentapp-crypt/gpgme: fix gcc-7 issue (diff)
downloadgentoo-0cd8f10f2c32a738f8828b6a7417d43895051cec.tar.gz
gentoo-0cd8f10f2c32a738f8828b6a7417d43895051cec.tar.bz2
gentoo-0cd8f10f2c32a738f8828b6a7417d43895051cec.zip
games-util/xgamer: Add build fix for Perl 5.26, bug 623594
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'games-util')
-rw-r--r--games-util/xgamer/files/xgamer-0.6.2-perl526.patch13
-rw-r--r--games-util/xgamer/xgamer-0.6.2.ebuild7
2 files changed, 18 insertions, 2 deletions
diff --git a/games-util/xgamer/files/xgamer-0.6.2-perl526.patch b/games-util/xgamer/files/xgamer-0.6.2-perl526.patch
new file mode 100644
index 000000000000..d59ba05263fb
--- /dev/null
+++ b/games-util/xgamer/files/xgamer-0.6.2-perl526.patch
@@ -0,0 +1,13 @@
+diff -ruN xgamer.orig/Build.PL xgamer/Build.PL
+--- xgamer.orig/Build.PL 2012-09-21 17:23:27.000000000 +0200
++++ xgamer/Build.PL 2017-07-08 20:33:44.566199833 +0200
+@@ -2,7 +2,8 @@
+
+ use strict;
+ use warnings;
+-
++
++use lib q[.];
+ use inc::MyBuilder;
+ use File::Spec::Functions;
+
diff --git a/games-util/xgamer/xgamer-0.6.2.ebuild b/games-util/xgamer/xgamer-0.6.2.ebuild
index 1cfa19c337b1..e139c04400f2 100644
--- a/games-util/xgamer/xgamer-0.6.2.ebuild
+++ b/games-util/xgamer/xgamer-0.6.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit perl-module
DESCRIPTION="A launcher for starting games in a second X session"
@@ -29,7 +29,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}
-PATCHES=( "${FILESDIR}"/${P}-desktopfile.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-desktopfile.patch
+ "${FILESDIR}"/${P}-perl526.patch
+)
pkg_postinst() {
elog "optional dependencies:"