summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-02-15 14:36:44 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-02-15 14:41:26 +0100
commit18e07a008aaf61494400ddf8b5bb018b4e37eb62 (patch)
tree983182332a6abeee6f5f122bf02760b88287171f /games-util
parentprofiles/base: Mask Cinnamon wayland support (diff)
downloadgentoo-18e07a008aaf61494400ddf8b5bb018b4e37eb62.tar.gz
gentoo-18e07a008aaf61494400ddf8b5bb018b4e37eb62.tar.bz2
gentoo-18e07a008aaf61494400ddf8b5bb018b4e37eb62.zip
games-util/lutris: fix byte-compile
Upstream lutris.net release tarball includes precompiled pyc files, switch to GitHub tarball and call python_optimize Closes: https://bugs.gentoo.org/923899 Closes: https://bugs.gentoo.org/923900 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lutris/Manifest2
-rw-r--r--games-util/lutris/lutris-0.5.16-r1.ebuild (renamed from games-util/lutris/lutris-0.5.16.ebuild)10
-rw-r--r--games-util/lutris/lutris-9999.ebuild12
3 files changed, 10 insertions, 14 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index ab28c0a469c1..5959e2aab4f0 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,3 +1,3 @@
+DIST lutris-0.5.16.gh.tar.gz 1637633 BLAKE2B 833ce9a690220c6bbcc3287f7ebcbad97a96a9f0d8307e9a94416a9779b5090605ed48e6c3254c64e4c3d90b3755fc2961c658ba93d5d8b5379df95c190624cc SHA512 be7e5ac7da0d023b46c7c22b2a9496593619e6e2f148938480704bcd41ba38f42c2b76cfee81aa62e31186344c9b8f6a23da3655e0d54e4710c94c0d722edb5e
DIST lutris_0.5.13.tar.xz 1565824 BLAKE2B 5326f7d671f91cab9e2f21377b939f33383098778751d2855d319b6f84b349108dce9a92faecf804e292cb711dfe6dc40a1ede591847b13550d25d83f51a9c7f SHA512 8ca257de9647a21774c9aaa251178a5f5b4eb137985913e136e27959880a356f95bd0ba6ba75059b92f7d92fdeee7f410592a39c60d8ec72412a3106a1561a7b
DIST lutris_0.5.14.tar.xz 4394748 BLAKE2B dc1a8089219ebd3ea42be45fe0dc942a6353ac69b30527a8766c7ae54bd09fb529296e5e63a717d8a1033e70b3a9ab52daa87d5287845e34e53d765aec41191d SHA512 1292ef9dfb9bc977d6b687319060451a615e27c2e056aeafb4db21bdb20fec2b051bb31230604c528860871bdde01f2385a5320467b74c8ad3b516574ce7fb27
-DIST lutris_0.5.16.tar.xz 1691896 BLAKE2B 314f00953b427831847dc0852063038f8991c4a151ca8eaa01a178873becb96a56b89f65e8213228eedde96113f5e8130edf96498542296192e2a2a597259e70 SHA512 c30c4d93cadc56902c46ab263c39566a42348ee38059d360e71095d3ff2f564703c6bad45f9ffd476ec04150b13c94f411fe3a7f1284622cc7910d0bdbf92c7e
diff --git a/games-util/lutris/lutris-0.5.16.ebuild b/games-util/lutris/lutris-0.5.16-r1.ebuild
index 2c3d1da23ab2..96ed02d2fc33 100644
--- a/games-util/lutris/lutris-0.5.16.ebuild
+++ b/games-util/lutris/lutris-0.5.16-r1.ebuild
@@ -15,12 +15,9 @@ if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/lutris/lutris.git"
inherit git-r3
else
- if [[ ${PV} == *_beta* ]] ; then
- SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}"/${P/_/-}
- else
- SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
- S="${WORKDIR}/${PN}"
+ SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}"/${P/_/-}
+ if [[ ${PV} != *_beta* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
fi
@@ -83,6 +80,7 @@ src_test() {
src_install() {
meson_src_install
+ python_optimize
python_fix_shebang "${ED}/usr/" #740048
}
diff --git a/games-util/lutris/lutris-9999.ebuild b/games-util/lutris/lutris-9999.ebuild
index 95411007384c..96ed02d2fc33 100644
--- a/games-util/lutris/lutris-9999.ebuild
+++ b/games-util/lutris/lutris-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,12 +15,9 @@ if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/lutris/lutris.git"
inherit git-r3
else
- if [[ ${PV} == *_beta* ]] ; then
- SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}"/${P/_/-}
- else
- SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
- S="${WORKDIR}/${PN}"
+ SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}"/${P/_/-}
+ if [[ ${PV} != *_beta* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
fi
@@ -83,6 +80,7 @@ src_test() {
src_install() {
meson_src_install
+ python_optimize
python_fix_shebang "${ED}/usr/" #740048
}