summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-17 18:24:06 -0400
committerSam James <sam@gentoo.org>2024-03-18 05:29:49 +0000
commit2e168edc0b956c00572a55d479161a000be1a2e3 (patch)
tree4ba07856dbfbd912069dc10bb463c79a79589ba8 /games-util
parentapp-pda/pilot-link: mark as LTO-unsafe (diff)
downloadgentoo-2e168edc0b956c00572a55d479161a000be1a2e3.tar.gz
gentoo-2e168edc0b956c00572a55d479161a000be1a2e3.tar.bz2
gentoo-2e168edc0b956c00572a55d479161a000be1a2e3.zip
games-util/wit: mark as LTO-unsafe
The build system already marks itself as strict-aliasing unsafe. Closes: https://bugs.gentoo.org/859319 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/wit/wit-3.02a.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/games-util/wit/wit-3.02a.ebuild b/games-util/wit/wit-3.02a.ebuild
index 95c5351036aa..aaeaa614fd02 100644
--- a/games-util/wit/wit-3.02a.ebuild
+++ b/games-util/wit/wit-3.02a.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
MY_P="wiimms-iso-tools.source-${PV}"
@@ -32,6 +32,13 @@ PATCHES=(
)
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/859319
+ #
+ # After investigation, the build system also uses -fno-strict-aliasing
+ # so do not trust it with LTO either, even if the type-mismatch gets fixed.
+ filter-lto
+
export NO_FUSE=$(usex fuse 0 1)
export NO_ZLIB=$(usex zlib 0 1)