summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-11-25 12:37:41 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-11-25 12:39:42 -0500
commit4fe59e92e50c3ca9486471d87b63acd6b9650eb7 (patch)
treea14f01cf5cff001b51968e17b1b706bb053788ff /games-util
parentnet-analyzer/nagios-check_linux_bonding: update EAPI 5 -> 8 (diff)
downloadgentoo-4fe59e92e50c3ca9486471d87b63acd6b9650eb7.tar.gz
gentoo-4fe59e92e50c3ca9486471d87b63acd6b9650eb7.tar.bz2
gentoo-4fe59e92e50c3ca9486471d87b63acd6b9650eb7.zip
games-util/ucon64: add 2.2.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/ucon64/Manifest1
-rw-r--r--games-util/ucon64/files/ucon64-2.2.2-respect-flags.patch29
-rw-r--r--games-util/ucon64/ucon64-2.2.2.ebuild63
3 files changed, 93 insertions, 0 deletions
diff --git a/games-util/ucon64/Manifest b/games-util/ucon64/Manifest
index 190c02eda09a..1128342e97df 100644
--- a/games-util/ucon64/Manifest
+++ b/games-util/ucon64/Manifest
@@ -1 +1,2 @@
DIST ucon64-2.2.1-src.tar.gz 1476080 BLAKE2B 8f7010bde2c7306f6a76dec4ce5e31975c286801e6504bf8bc99287bd7adc4ab10331a8cab308fed83ece9e13bdb01327f6d3439eba776038dbb19eb2b72cf70 SHA512 34453399151e5ed256fdcf387b9d32a052718b264e51b99a2be251b90589337d13cd317f8d1aa7d3c8e39c8e407b22797d4608ec6d14b99c8673ec74f349f6c2
+DIST ucon64-2.2.2-src.tar.gz 1481087 BLAKE2B 3ae3d09f4ea186d4e64d712bf0e3036ca79b7e87ba9a9b165fdcee2f0e24ac1dd00a5da9653a404850e8bc1f85cd6b26e0d03615e60090709d9b792c3db07e8e SHA512 21e403e6de64c0a76de32032fbafea75f53a96b88b343220cdc8d62ef3bdec252764cacb9bbf98a910477ba451bc05aee8c9f91024b9e5d3149f7ead20d426b5
diff --git a/games-util/ucon64/files/ucon64-2.2.2-respect-flags.patch b/games-util/ucon64/files/ucon64-2.2.2-respect-flags.patch
new file mode 100644
index 000000000000..9e772fe6c76a
--- /dev/null
+++ b/games-util/ucon64/files/ucon64-2.2.2-respect-flags.patch
@@ -0,0 +1,29 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,3 +13,3 @@
+
+-CFLAGS+=-I. -Wall -W -Wno-implicit-fallthrough -O3 -fsigned-char
++CFLAGS+=-I. -Wall -W -Wno-implicit-fallthrough -fsigned-char
+ ifneq ($(findstring clang,$(CC)),clang)
+@@ -21,3 +21,2 @@
+ # ld: warning: option -s is obsolete and being ignored
+-LDFLAGS+=-s
+ endif
+--- a/backup/libcd64/Makefile
++++ b/backup/libcd64/Makefile
+@@ -1,3 +1,2 @@
+ ifeq ($(CC),cc)
+-CC=gcc
+ endif
+@@ -12,5 +11,3 @@
+ else
+-CFLAGS+=-O3 -funroll-loops
+ ifneq ($(findstring clang,$(CC)),clang)
+-CFLAGS+=-fexpensive-optimizations
+ endif
+--- a/libdiscmage/Makefile.in
++++ b/libdiscmage/Makefile.in
+@@ -37,3 +37,2 @@
+ # /usr/bin/libtool: -static not specified, -s invalid
+-LDFLAGS+=-s
+ endif
diff --git a/games-util/ucon64/ucon64-2.2.2.ebuild b/games-util/ucon64/ucon64-2.2.2.ebuild
new file mode 100644
index 000000000000..617f85487c0d
--- /dev/null
+++ b/games-util/ucon64/ucon64-2.2.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="The backup tool and wonderful emulator's Swiss Army knife program"
+HOMEPAGE="http://ucon64.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ucon64/${P}-src.tar.gz"
+S="${WORKDIR}/${P}-src/src"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug usb zlib"
+
+RDEPEND="
+ usb? ( virtual/libusb:0 )
+ zlib? ( sys-libs/zlib:= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-flags.patch
+)
+
+src_prepare() {
+ default
+
+ sed "/discmage.so/s|.* \"|\"${EPREFIX}/usr/$(get_libdir)/${PN}/|" \
+ -i ucon64_misc.c || die
+}
+
+src_configure() {
+ local econfargs=(
+ $(use_enable debug)
+ $(use_with usb libusb)
+ $(use_with zlib)
+ --enable-ppdev
+ --with-libcd64
+ --with-libdiscmage
+ )
+ econf "${econfargs[@]}"
+
+ tc-export AR CC LD
+}
+
+src_install() {
+ dobin ucon64
+
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe libdiscmage/discmage.so
+
+ docinto html
+ dodoc -r ../images ../{changes,developers,faq,hardware,readme}.html
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Be sure to check ~/.ucon64rc for some options after"
+ elog "you've run uCON64 for the first time."
+ fi
+}