summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-22 17:43:50 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-22 17:43:50 +0100
commit5a362eb9543216d757cd05899853951968845055 (patch)
treee2697b9810febb55fe5a28f01dae50179f712037 /games-util
parentdev-util/include-what-you-use: bump up to 0.15 (diff)
downloadgentoo-5a362eb9543216d757cd05899853951968845055.tar.gz
gentoo-5a362eb9543216d757cd05899853951968845055.tar.bz2
gentoo-5a362eb9543216d757cd05899853951968845055.zip
games-util/etswitch: Port to EAPI 7
Closes: https://bugs.gentoo.org/706950 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/etswitch/etswitch-0.1.14-r1.ebuild17
-rw-r--r--games-util/etswitch/files/etswitch-0.1.14-fno-common.patch22
2 files changed, 29 insertions, 10 deletions
diff --git a/games-util/etswitch/etswitch-0.1.14-r1.ebuild b/games-util/etswitch/etswitch-0.1.14-r1.ebuild
index da46e7ba4978..61b5ce230018 100644
--- a/games-util/etswitch/etswitch-0.1.14-r1.ebuild
+++ b/games-util/etswitch/etswitch-0.1.14-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="*nix minimizer for a few games"
HOMEPAGE="http://hem.bredband.net/b400150/"
@@ -10,9 +10,9 @@ SRC_URI="http://hem.bredband.net/b400150/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXxf86vm
x11-libs/libXmu
x11-libs/libXpm"
@@ -21,10 +21,7 @@ DEPEND="${RDEPEND}
x11-base/xorg-proto"
PATCHES=(
- "${FILESDIR}"/${P}-desktop-entry.patch
- "${FILESDIR}"/${P}-glibc.patch
+ "${FILESDIR}"/${P}-desktop-entry.patch
+ "${FILESDIR}"/${P}-glibc.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
-
-src_configure() {
- econf --datadir=/usr/share
-}
diff --git a/games-util/etswitch/files/etswitch-0.1.14-fno-common.patch b/games-util/etswitch/files/etswitch-0.1.14-fno-common.patch
new file mode 100644
index 000000000000..f0bdebcb6a76
--- /dev/null
+++ b/games-util/etswitch/files/etswitch-0.1.14-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/src/read_wid.c
++++ b/src/read_wid.c
+@@ -62,6 +62,8 @@
+ #include <errno.h>
+ extern int errno;
+
++wid_info_struct *wid;
++
+ /*
+ will try and read the wid file and malloc the game struct
+ if wid file is missing it will read the internal one
+--- a/src/read_wid.h
++++ b/src/read_wid.h
+@@ -38,7 +38,7 @@
+ char *first_struct;
+ } wid_info_struct;
+
+-wid_info_struct *wid; /* global wid array */
++extern wid_info_struct *wid; /* global wid array */
+
+
+