summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-11-06 21:35:45 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-11-06 21:35:45 +0000
commit5ec6155ac4f96a502512be1936aadc5cf26ae57f (patch)
treebda48c8ab82ee6760689360a58bd7888ee445b4d /games-util
parentdev-util/git-delta: arm64 keyworded (bug #753038) (diff)
downloadgentoo-5ec6155ac4f96a502512be1936aadc5cf26ae57f.tar.gz
gentoo-5ec6155ac4f96a502512be1936aadc5cf26ae57f.tar.bz2
gentoo-5ec6155ac4f96a502512be1936aadc5cf26ae57f.zip
games-util/sc-controller: New package
This was sys-apps/sc-controller in steam-overlay. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/sc-controller/Manifest1
-rw-r--r--games-util/sc-controller/files/status-icon-click.patch28
-rw-r--r--games-util/sc-controller/metadata.xml11
-rw-r--r--games-util/sc-controller/sc-controller-0.4.8.1.ebuild33
4 files changed, 73 insertions, 0 deletions
diff --git a/games-util/sc-controller/Manifest b/games-util/sc-controller/Manifest
new file mode 100644
index 000000000000..319725439883
--- /dev/null
+++ b/games-util/sc-controller/Manifest
@@ -0,0 +1 @@
+DIST sc-controller-0.4.8.1.tar.gz 2520167 BLAKE2B 40c8e366519ec2a6d80b31c2b342fba2664fa35f3a889e222665f8f5cd4d59dd912804f6cdf4ecd844ab94075f5f45f88a61138ac1c0cb528652c9fd9b710afa SHA512 bc57bd381c71e94c0771ecdb08f95326d0c1478e25cdf3955b71c203abe6cb78091ca977deb8a1e954b5b1b65a6df487f8b8921920b1eb672aa6f1f5554a4847
diff --git a/games-util/sc-controller/files/status-icon-click.patch b/games-util/sc-controller/files/status-icon-click.patch
new file mode 100644
index 000000000000..46b39553b483
--- /dev/null
+++ b/games-util/sc-controller/files/status-icon-click.patch
@@ -0,0 +1,28 @@
+From b1388d0e768f0bedd5704ffae9b13500ad325308 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Sat, 17 Oct 2020 21:36:49 +0100
+Subject: [PATCH] Fix TypeError when clicking on the status icon
+
+The error was:
+
+ TypeError: GObject.emit() argument 1 must be str, not bytes
+---
+ scc/gui/statusicon.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/scc/gui/statusicon.py b/scc/gui/statusicon.py
+index 61ef9e96..83600492 100644
+--- a/scc/gui/statusicon.py
++++ b/scc/gui/statusicon.py
+@@ -322,7 +322,7 @@ class StatusIconProxy(StatusIcon):
+ self._load_fallback()
+
+ def _on_click(self, *args):
+- self.emit(b"clicked")
++ self.emit("clicked")
+
+ def _on_notify_active_gtk(self, *args):
+ if self._status_fb:
+--
+2.26.2
+
diff --git a/games-util/sc-controller/metadata.xml b/games-util/sc-controller/metadata.xml
new file mode 100644
index 000000000000..e3a736ee87d1
--- /dev/null
+++ b/games-util/sc-controller/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Ryochan7/sc-controller</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/sc-controller/sc-controller-0.4.8.1.ebuild b/games-util/sc-controller/sc-controller-0.4.8.1.ebuild
new file mode 100644
index 000000000000..f5cb8a83901e
--- /dev/null
+++ b/games-util/sc-controller/sc-controller-0.4.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="User-mode driver and GTK-based GUI for Steam Controllers and others"
+HOMEPAGE="https://github.com/Ryochan7/sc-controller/"
+SRC_URI="https://github.com/Ryochan7/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2 CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+udev"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject[${PYTHON_USEDEP},cairo]
+ dev-python/pylibacl[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ ')
+ gnome-base/librsvg
+ x11-libs/gtk+:3
+ udev? ( games-util/game-device-udev-rules )
+"
+
+PATCHES=(
+ "${FILESDIR}"/status-icon-click.patch
+)