summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-10-31 22:28:48 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-10-31 22:29:28 +0000
commit601e261fefe2a143f09db67637e1527074a9a802 (patch)
tree42dffadcda1eddd4575e79d8685d69d9e9014517 /games-util
parentapp-portage/tatt: add 0.9 (diff)
downloadgentoo-601e261fefe2a143f09db67637e1527074a9a802.tar.gz
gentoo-601e261fefe2a143f09db67637e1527074a9a802.tar.bz2
gentoo-601e261fefe2a143f09db67637e1527074a9a802.zip
games-util/mcrcon: Version bump to 0.7.2, EAPI 8
For reals, this time! Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/mcrcon/Manifest1
-rw-r--r--games-util/mcrcon/mcrcon-0.7.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/games-util/mcrcon/Manifest b/games-util/mcrcon/Manifest
index 72640d639535..06a1d53e25f5 100644
--- a/games-util/mcrcon/Manifest
+++ b/games-util/mcrcon/Manifest
@@ -1 +1,2 @@
DIST mcrcon-0.7.1.tar.gz 9796 BLAKE2B 4de98574783f995b5161944dac3a817313618019f1711832d266f038ce7a56a2e3d6da2556dbcd36870dd81de74f9886db84af81d9e6c25d70155f61c4a7f191 SHA512 372314e007d50e758203911c25df7c07d317ea6a7e469e24f603eae67ec5ef1e313c997481f4d90395d25d4d99ddc126a6e5745b2044903b2f21271aa7c39eb2
+DIST mcrcon-0.7.2.tar.gz 9997 BLAKE2B 3dabd5c1951bd4427486a7a0c438730d61e9ebf006de77225b17153964728d671821e60ddb9d0a3d53952c4331e4d4807cb9b96009c37427eb4bc1f684664f3e SHA512 584487bd6d3d2d0ddd0065187c5cadf7c1cf80c8234acb55f218eab6a54c10a7e99adf0ca643894f3664d51233cd04745fb13c4ee02964ef735c034b01f2ee89
diff --git a/games-util/mcrcon/mcrcon-0.7.2.ebuild b/games-util/mcrcon/mcrcon-0.7.2.ebuild
new file mode 100644
index 000000000000..80b64e933516
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.7.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="https://github.com/Tiiffi/mcrcon"
+SRC_URI="https://github.com/Tiiffi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS} -std=gnu99 -Wall -Wextra -Wpedantic"
+}
+
+src_install() {
+ emake install PREFIX="${ED}/usr"
+}