summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-13 01:16:31 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-13 01:16:31 -0500
commit6366d88efec6f14a27a0b6879a7f02f5e205cadf (patch)
treeba07762a800941245f3bde66085b4db51ad6a7d6 /games-util
parentgames-util/xpadneo: remove ertm warning (diff)
downloadgentoo-6366d88efec6f14a27a0b6879a7f02f5e205cadf.tar.gz
gentoo-6366d88efec6f14a27a0b6879a7f02f5e205cadf.tar.bz2
gentoo-6366d88efec6f14a27a0b6879a7f02f5e205cadf.zip
games-util/xpadneo: add 0.9.6
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/xpadneo/Manifest1
-rw-r--r--games-util/xpadneo/xpadneo-0.9.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/games-util/xpadneo/Manifest b/games-util/xpadneo/Manifest
index 163427b7e98b..8b085b23eedf 100644
--- a/games-util/xpadneo/Manifest
+++ b/games-util/xpadneo/Manifest
@@ -1 +1,2 @@
DIST xpadneo-0.9.5.tar.gz 1341366 BLAKE2B d04a3e1b626af1f1a9ec114f0a8ed44c50ec8cde9da71483491d1afd7688611fd7548186ea68ef8a144aecec06acba816e81e9f0708c8dceb96fa1d40985bb44 SHA512 e7e299faf78c139d4cd189c4adc9bcbd52e1e1011ff90513cc09fc3e6cac1961018883933ad1db23dc02c8d5006f3166fbb42ae66150dff71138f2ed95f4576c
+DIST xpadneo-0.9.6.tar.gz 1344171 BLAKE2B 22a85732de2894d310e0994c101ed62b7358f1b6b8ba5b389fc273bfd48a1ce619ebc04f3699818290f61833234d4c444fff25ea852d9dcf420b99ab28687a03 SHA512 f423fb89cf911c727917591d79909acaecc9fdb68ca10c5cc2a128bd66174799f3efb2b9a87e43bb315ab92ddb7513f79300f06d347fabc9de11e63fc1d25689
diff --git a/games-util/xpadneo/xpadneo-0.9.6.ebuild b/games-util/xpadneo/xpadneo-0.9.6.ebuild
new file mode 100644
index 000000000000..d57edd3bce17
--- /dev/null
+++ b/games-util/xpadneo/xpadneo-0.9.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1 udev
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/atar-axis/xpadneo.git"
+ EGIT_MIN_CLONE_TYPE="single"
+else
+ SRC_URI="https://github.com/atar-axis/xpadneo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Advanced Linux Driver for Xbox One Wireless Controller"
+HOMEPAGE="https://atar-axis.github.io/xpadneo/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+CONFIG_CHECK="INPUT_FF_MEMLESS"
+
+src_compile() {
+ local modlist=( hid-${PN}=kernel/drivers/hid:hid-${PN}:hid-${PN}/src )
+ local modargs=( KERNEL_SOURCE_DIR="${KV_OUT_DIR}" )
+
+ linux-mod-r1_src_compile
+}
+
+src_install() {
+ local DOCS=( docs/{[^i]*.md,descriptors,reports} NEWS.md )
+ linux-mod-r1_src_install
+
+ insinto /etc/modprobe.d
+ doins hid-${PN}/etc-modprobe.d/${PN}.conf
+
+ udev_dorules hid-${PN}/etc-udev-rules.d/60-${PN}.rules
+}
+
+pkg_postinst() {
+ linux-mod-r1_pkg_postinst
+ udev_reload
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To pair the gamepad and view module options, see documentation in:"
+ elog " ${EROOT}/usr/share/doc/${PF}/"
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+}