summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-01-15 09:06:08 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-01-15 09:07:50 +0200
commit65e50f87e3f3ba312e57214a01a6b99cb10b5924 (patch)
tree26c4ec2149ade9b94f64647ce52c8effde714570 /games-util
parentwww-apps/postfixadmin: bugfix bump to 3.3.3 (diff)
downloadgentoo-65e50f87e3f3ba312e57214a01a6b99cb10b5924.tar.gz
gentoo-65e50f87e3f3ba312e57214a01a6b99cb10b5924.tar.bz2
gentoo-65e50f87e3f3ba312e57214a01a6b99cb10b5924.zip
games-util/xboxdrv: python-3.8 compatibility, fix kernel config checks
Closes: https://bugs.gentoo.org/710848 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild b/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild
index 76f9f0a91fc9..fe9386eaac63 100644
--- a/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild
+++ b/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit linux-info python-any-r1 scons-utils toolchain-funcs systemd udev
@@ -38,6 +38,11 @@ S="${WORKDIR}/${PN}-${COMMIT}"
CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"
+pkg_setup() {
+ linux-info_pkg_setup
+ python_setup
+}
+
src_prepare() {
default