summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2024-02-07 15:56:51 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-02-07 15:59:31 +0200
commita306afc2dc7ab19d922dfa6c7e32094358bd5e7d (patch)
treea793ca43ebee26540cce7178613a85b60e431343 /games-util
parentgames-util/gamemode: Update 9999 (diff)
downloadgentoo-a306afc2dc7ab19d922dfa6c7e32094358bd5e7d.tar.gz
gentoo-a306afc2dc7ab19d922dfa6c7e32094358bd5e7d.tar.bz2
gentoo-a306afc2dc7ab19d922dfa6c7e32094358bd5e7d.zip
games-util/gamemode: add 1.8.1
Closes: https://bugs.gentoo.org/696460 Signed-off-by: Kai Krakow <kai@kaishome.de> Closes: https://github.com/gentoo/gentoo/pull/34162 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/gamemode/Manifest1
-rw-r--r--games-util/gamemode/gamemode-1.8.1.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/games-util/gamemode/Manifest b/games-util/gamemode/Manifest
index b1c74c46c800..a0bb96e61c70 100644
--- a/games-util/gamemode/Manifest
+++ b/games-util/gamemode/Manifest
@@ -1 +1,2 @@
DIST gamemode-1.7.tar.xz 73264 BLAKE2B 81957a1989cf49532b0d80fc9b96a75d8205e7f148125309f3cae601f6fe125e8d839d4b92bea418a229a6e2658eaa55db2b3bbdb5e7efb26d278e2b22ab8269 SHA512 1fc91367af37d18e0042831b377cafec122c603ab699ecc314b0ded11410aab1bd739712e7305e497796fda25bee88d34438d5f3751595bf579dcbeb7335d15b
+DIST gamemode-1.8.1.tar.xz 78284 BLAKE2B de78c97b61cebd1f4cc29f0ab5c353e8db668eca3d6d8c65fa0cdbc167b1b172d3371e85bcb4cb193c043f0917127bc3a76ebd7de158555af6d145b1e8eb93d7 SHA512 7bfe7d34b422a87c2f53e69b44649a1aca7eba9fb08daa52e7e2f521fea0744e8f03b666c4dd684ad85ccadde20bc2edfb716d67a103629baa690051b8836554
diff --git a/games-util/gamemode/gamemode-1.8.1.ebuild b/games-util/gamemode/gamemode-1.8.1.ebuild
new file mode 100644
index 000000000000..746c7b5239eb
--- /dev/null
+++ b/games-util/gamemode/gamemode-1.8.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit meson-multilib systemd
+
+DESCRIPTION="Optimise Linux system performance on demand"
+HOMEPAGE="https://github.com/FeralInteractive/gamemode"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/FeralInteractive/gamemode.git"
+ GAMEMODE_GIT_PTR="master"
+ inherit git-r3
+else
+ GAMEMODE_GIT_PTR="${PV}"
+ SRC_URI="https://github.com/FeralInteractive/gamemode/releases/download/${GAMEMODE_GIT_PTR}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="systemd elogind"
+
+REQUIRED_USE="^^ ( systemd elogind )"
+
+RDEPEND="
+ acct-group/gamemode
+ >=dev-libs/inih-54
+ sys-apps/dbus[${MULTILIB_USEDEP},systemd(+)=,elogind(-)=]
+ sys-auth/polkit
+ sys-libs/libcap
+"
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ CHANGELOG.md
+ LICENSE.txt
+ README.md
+ example/gamemode.ini
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dwith-examples=false
+ -Dwith-pam-limits-dir="${EPREFIX}"/etc/security/limits.d
+ -Dwith-pam-renicing=true
+ -Dwith-privileged-group=gamemode
+ -Dwith-systemd-user-unit-dir="$(systemd_get_userunitdir)"
+ )
+ if multilib_is_native_abi; then
+ emesonargs+=(
+ -Dwith-sd-bus-provider=$(usex systemd systemd elogind)
+ -Dwith-util=true
+ )
+ else
+ emesonargs+=(
+ -Dwith-sd-bus-provider=no-daemon
+ -Dwith-util=false
+ )
+ fi
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ elog
+ elog "GameMode requires permissions to adjust your PAM limits and change system"
+ elog "performance settings (overclocking, scheduling, L2 cache usage, mitigations"
+ elog "etc). This permission is granted via the gamemode group."
+ elog
+ elog "Run the following command as root to add your user:"
+ elog "# gpasswd -a USER gamemode # with USER = your user name"
+ elog
+ elog "You can run the following command to test your settings:"
+ elog
+ elog "# gamemoded -t"
+ elog
+ elog "GameMode supports GPU optimizations. It defaults to OFF. Any damage"
+ elog "resulting from usage of this is your own responsibility. For safety"
+ elog "reasons, GPU settings are not allowed from \$HOME but only from"
+ elog "administrative directories."
+ elog
+ elog "systemd user sessions will automatically run the daemon on demand, it does"
+ elog "not need to be enabled explicitly. Games not supporting GameMode natively"
+ elog "can still make use of it, just add"
+ elog
+ elog "gamemoderun %command%"
+ elog
+ elog "to the start options of any Steam game to enable optimizations automatically"
+ elog "as you start the game. Similar options exist for other launchers like"
+ elog "Bottles or Lutris."
+ elog
+}