summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-29 20:35:26 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-29 21:04:10 +0200
commitc89bc502532518bf7fc83351b833f066e8065030 (patch)
treeb2ab827f125193ffed8cb8e2ee9c8dad17fc7846 /games-util
parentgnustep-libs/dbuskit: drop old EAPI5 ebuild (diff)
downloadgentoo-c89bc502532518bf7fc83351b833f066e8065030.tar.gz
gentoo-c89bc502532518bf7fc83351b833f066e8065030.tar.bz2
gentoo-c89bc502532518bf7fc83351b833f066e8065030.zip
games-util/lutris: add version 0.5.9.1
- We add a patch that avoids: importError (Requiring namespace 'Gtk' version '3.0', but '4.0' is already loaded) - And we remove the sed line that makes the application fail to find data_path during runtime, the test that this claims to fix works (for me) without this sed line anyway. Bug: https://bugs.gentoo.org/811285 - Bumped to EAPI 8 - Also update 9999 accordingly Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/files/lutris-0.5.9.1-avoid-gtk-4.0-already-loaded-testerror.patch13
-rw-r--r--games-util/lutris/lutris-0.5.9.1.ebuild80
-rw-r--r--games-util/lutris/lutris-9999.ebuild21
4 files changed, 100 insertions, 15 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index 788ed8e296fb..04f4d8139098 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,3 +1,4 @@
DIST lutris-0.5.9_beta1.tar.gz 836915 BLAKE2B 53133b202e45a2e68e5aca273cd591055d469a2ada39d2b75db92d45da45a53cf3425b1d36fea1a7f241b9336895ada8b8e4577374cd0b1fd996cbd3f5108b1b SHA512 48b433fcf03795874e6c7f0b4d310f7a779c831ea67e754a0c9bb0b919f9f050311b002d63fa34150be753c4de452c306db16cb43c00fa91b08775c68169b7e6
DIST lutris_0.5.8.3.tar.xz 942716 BLAKE2B f831c6ad6f67c3948f07e89f9caacd0d8aa3878b912fe987afea85eea549f41347044967255fa80e4e0c4544d148d9782dfe3c5bf08a123436e8a5ef7034901f SHA512 8f653d38a9a551298fa344cde67d53bf50cfd2a0a0667e344d04f6e17dda4ef358037755975d1a7f74ecd39824d58f9586e8a82b70dccc26619f22fee94d1144
DIST lutris_0.5.8.4.tar.xz 957004 BLAKE2B f3acce5d9ea7368063a3135c1f503e0644c1cbc7676e966c262c8e04c5e0d23b4882793fe2df1beab265ab4128e8a90b5bb69401f8e567b0cceeea3008ff4fa7 SHA512 f79a9fd06788bc28e59ad6d2c403b83f8bdeaee0116ae7fbf765e80e4e08bf760a462c71f75a2ff46739e5757cb8609f5110a51d83266d3aba2f0c91524b6df9
+DIST lutris_0.5.9.1.tar.xz 1046920 BLAKE2B 469e7707e74d957be3bb0f5f1caeaeaaf7c01dc3b998c16d8be4b4b780e408763bbe0df5c0b5f6a53ebcb3eb478aaaf25f9cf16437ae682dfcd1d2213222fa18 SHA512 a94e37d1a3f5b80353af38900f3e67763af9c0e3cc3013f7998e23ff70cb6f329730b1802f996866dac541af6e50388a5308c772e3a2ee97f87e5ae60878e7e7
diff --git a/games-util/lutris/files/lutris-0.5.9.1-avoid-gtk-4.0-already-loaded-testerror.patch b/games-util/lutris/files/lutris-0.5.9.1-avoid-gtk-4.0-already-loaded-testerror.patch
new file mode 100644
index 000000000000..8c0d366926b7
--- /dev/null
+++ b/games-util/lutris/files/lutris-0.5.9.1-avoid-gtk-4.0-already-loaded-testerror.patch
@@ -0,0 +1,13 @@
+diff --git a/lutris/util/test_config.py b/lutris/util/test_config.py
+index b3feb87..01b9294 100644
+--- a/lutris/util/test_config.py
++++ b/lutris/util/test_config.py
+@@ -1,5 +1,8 @@
+ import os
+
++import gi
++gi.require_version('Gtk', '3.0')
++
+ from lutris import startup
+ from lutris.database import schema
+
diff --git a/games-util/lutris/lutris-0.5.9.1.ebuild b/games-util/lutris/lutris-0.5.9.1.ebuild
new file mode 100644
index 000000000000..683abd5de58b
--- /dev/null
+++ b/games-util/lutris/lutris-0.5.9.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+DISTUTILS_SINGLE_IMPL="1"
+
+inherit distutils-r1 virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
+ inherit git-r3
+else
+ if [[ ${PV} == *_beta* ]] ; then
+ SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${P/_/-}
+ else
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+ fi
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gnome-desktop:3[introspection]
+ media-sound/fluid-soundfont
+ net-libs/libsoup
+ net-libs/webkit-gtk:4[introspection]
+ x11-apps/mesa-progs
+ x11-apps/xgamma
+ x11-apps/xrandr
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS README.rst docs/installers.rst docs/steam.rst )
+
+PATCHES=( "${FILESDIR}/${P}-avoid-gtk-4.0-already-loaded-testerror.patch" )
+
+python_test() {
+ virtx epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ python_fix_shebang "${ED}/usr/share/lutris/bin/lutris-wrapper" #740048
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Quote README.rst
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
+}
diff --git a/games-util/lutris/lutris-9999.ebuild b/games-util/lutris/lutris-9999.ebuild
index 4ca63a7a2a1f..fa2c19860a63 100644
--- a/games-util/lutris/lutris-9999.ebuild
+++ b/games-util/lutris/lutris-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL="1"
@@ -54,26 +54,17 @@ RDEPEND="
x11-libs/libnotify[introspection]
"
-distutils_enable_tests nose
+distutils_enable_tests pytest
-src_prepare() {
- default
-
- # Avoid test failure:
- # "ERROR: Failure: OSError (data_path can't be found at : /usr/share/lutris)"
- sed -i -e "s:sys.path\[0\]:\"${S}/share\":" lutris/util/datapath.py || die
-
- distutils-r1_src_prepare
-}
+DOCS=( AUTHORS README.rst docs/installers.rst docs/steam.rst )
python_test() {
- virtx nosetests -v
+ virtx epytest
}
python_install_all() {
- local DOCS=( AUTHORS README.rst docs/installers.rst )
distutils-r1_python_install_all
- python_fix_shebang "${ED}"/usr/share/lutris/bin/lutris-wrapper #740048
+ python_fix_shebang "${ED}/usr/share/lutris/bin/lutris-wrapper" #740048
}
pkg_postinst() {