summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-22 16:53:22 +0200
committerMart Raudsepp <leio@gentoo.org>2020-03-22 17:21:29 +0200
commitb16695117527e1050abe3ec35cc84d599ac0dd69 (patch)
tree17e8f941c01f0e797a924e6ddd96ed946931b391 /gnome-base/dconf-editor/dconf-editor-3.34.4.ebuild
parentdev-lang/erlang: sparc stable wrt bug #713910 (diff)
downloadgentoo-b16695117527e1050abe3ec35cc84d599ac0dd69.tar.gz
gentoo-b16695117527e1050abe3ec35cc84d599ac0dd69.tar.bz2
gentoo-b16695117527e1050abe3ec35cc84d599ac0dd69.zip
gnome-base/dconf-editor: bump to 3.34.4
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-base/dconf-editor/dconf-editor-3.34.4.ebuild')
-rw-r--r--gnome-base/dconf-editor/dconf-editor-3.34.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-base/dconf-editor/dconf-editor-3.34.4.ebuild b/gnome-base/dconf-editor/dconf-editor-3.34.4.ebuild
new file mode 100644
index 000000000000..bda15a665222
--- /dev/null
+++ b/gnome-base/dconf-editor/dconf-editor-3.34.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/dconf-editor"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-linux"
+
+RDEPEND="
+ >=gnome-base/dconf-0.26.1
+ >=dev-libs/glib-2.55.1:2
+ >=x11-libs/gtk+-3.22.27:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}