summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-12 17:56:33 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-12 17:59:33 -0400
commit21aad7be25d6be120f79e17dc1f8d8ee91ff354a (patch)
treeb8efce546778b05fd215d7818c5ce48561e69039 /gnome-base/dconf-editor/dconf-editor-3.38.3.ebuild
parentgnome-base/dconf: Drop old versions (diff)
downloadgentoo-21aad7be25d6be120f79e17dc1f8d8ee91ff354a.tar.gz
gentoo-21aad7be25d6be120f79e17dc1f8d8ee91ff354a.tar.bz2
gentoo-21aad7be25d6be120f79e17dc1f8d8ee91ff354a.zip
gnome-base/dconf-editor: Version bump to 3.38.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base/dconf-editor/dconf-editor-3.38.3.ebuild')
-rw-r--r--gnome-base/dconf-editor/dconf-editor-3.38.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-base/dconf-editor/dconf-editor-3.38.3.ebuild b/gnome-base/dconf-editor/dconf-editor-3.38.3.ebuild
new file mode 100644
index 000000000000..a1530c400860
--- /dev/null
+++ b/gnome-base/dconf-editor/dconf-editor-3.38.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/dconf-editor"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+
+RDEPEND="
+ >=gnome-base/dconf-0.26.1
+ >=dev-libs/glib-2.55.1:2
+ >=x11-libs/gtk+-3.22.27:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}