summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-05-08 11:12:24 +0200
committerPacho Ramos <pacho@gentoo.org>2021-05-08 11:27:35 +0200
commit49b129e42914ee796c5e9afb5436a1d53468a747 (patch)
tree925da676b00aba2be1a91520e4ca457395025d66 /gnome-base/gnome-applets
parentapp-cdr/brasero: Port to tracker-3 (diff)
downloadgentoo-49b129e42914ee796c5e9afb5436a1d53468a747.tar.gz
gentoo-49b129e42914ee796c5e9afb5436a1d53468a747.tar.bz2
gentoo-49b129e42914ee796c5e9afb5436a1d53468a747.zip
gnome-base/gnome-applets: 3.40 was ported to tracker-3
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-base/gnome-applets')
-rw-r--r--gnome-base/gnome-applets/gnome-applets-3.40.0-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnome-base/gnome-applets/gnome-applets-3.40.0-r1.ebuild b/gnome-base/gnome-applets/gnome-applets-3.40.0-r1.ebuild
new file mode 100644
index 000000000000..4320fd2e92f1
--- /dev/null
+++ b/gnome-base/gnome-applets/gnome-applets-3.40.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2
+
+DESCRIPTION="Applets for the GNOME Flashback Panel"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-applets/"
+
+LICENSE="GPL-2+ FDL-1.1"
+SLOT="0"
+IUSE="tracker"
+KEYWORDS="~amd64"
+
+# FIXME: automagic wireless-tools
+# TODO: gucharmap could be optional, but no knob
+# TODO: libgweather could be optional, but no knob
+RDEPEND="
+ >=x11-libs/gtk+-3.20.0:3[X]
+ >=dev-libs/glib-2.44.0:2
+ >=gnome-base/gnome-panel-3.37.0
+ >=gnome-base/libgtop-2.11.92:=
+ >=x11-libs/libwnck-3.14.1:3
+ >=x11-libs/libnotify-0.7
+ >=x11-themes/adwaita-icon-theme-3.14.0
+ >=dev-libs/libxml2-2.5.0:2
+ >=dev-libs/libgweather-3.28.0:2=
+ >=gnome-extra/gucharmap-2.33.0:2.90
+ >=sys-auth/polkit-0.97
+ x11-libs/libX11
+ tracker? ( app-misc/tracker:3 )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+# app-text/docbook-sgml-utils for jw binary
+BDEPEND="
+ app-text/docbook-sgml-utils
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+" # yelp-tools and autoconf-archive for eautoreconf
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-cpufreq \
+ $(use_enable tracker tracker-search-bar)
+}