summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/gnome-core-libs/gnome-core-libs-3.14.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/gnome-core-libs/gnome-core-libs-3.14.0.ebuild')
-rw-r--r--gnome-base/gnome-core-libs/gnome-core-libs-3.14.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnome-base/gnome-core-libs/gnome-core-libs-3.14.0.ebuild b/gnome-base/gnome-core-libs/gnome-core-libs-3.14.0.ebuild
new file mode 100644
index 000000000000..185da639cd23
--- /dev/null
+++ b/gnome-base/gnome-core-libs/gnome-core-libs-3.14.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Sub-meta package for the core libraries of GNOME 3"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="3.0"
+IUSE="cups python"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+# Note to developers:
+# This is a wrapper for the core libraries used by GNOME 3
+RDEPEND="
+ >=dev-libs/glib-2.42.0:2
+ >=x11-libs/gdk-pixbuf-2.30.8:2
+ >=x11-libs/pango-1.36.8
+ >=media-libs/clutter-1.20.0:1.0
+ >=x11-libs/gtk+-${PV}:3[cups?]
+ >=dev-libs/atk-2.14
+ >=x11-libs/libwnck-3.14:3
+ >=gnome-base/librsvg-2.40.2
+ >=gnome-base/gnome-desktop-${PV}:3
+ >=x11-libs/startup-notification-0.12
+
+ >=gnome-base/gvfs-1.22.1
+ >=gnome-base/dconf-0.22.0
+
+ || (
+ >=media-libs/gstreamer-0.10.36:0.10
+ >=media-libs/gstreamer-1.2.3:1.0 )
+ || (
+ >=media-libs/gst-plugins-base-0.10.36:0.10
+ >=media-libs/gst-plugins-base-1.2.3:1.0 )
+ || (
+ >=media-libs/gst-plugins-good-0.10.31:0.10
+ >=media-libs/gst-plugins-good-1.2.3:1.0 )
+
+ python? ( >=dev-python/pygobject-${PV}:3 )
+"
+DEPEND=""
+
+S="${WORKDIR}"