summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/gnome-desktop/gnome-desktop-2.32.1-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/gnome-desktop/gnome-desktop-2.32.1-r2.ebuild')
-rw-r--r--gnome-base/gnome-desktop/gnome-desktop-2.32.1-r2.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/gnome-base/gnome-desktop/gnome-desktop-2.32.1-r2.ebuild b/gnome-base/gnome-desktop/gnome-desktop-2.32.1-r2.ebuild
new file mode 100644
index 000000000000..f1e03e35cc7c
--- /dev/null
+++ b/gnome-base/gnome-desktop/gnome-desktop-2.32.1-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Libraries for the gnome desktop that are not part of the UI"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2+ FDL-1.1+ LGPL-2+"
+SLOT="2"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="license-docs"
+
+# Note: gnome-desktop:2 and :3 install identical files in /usr/share/gnome/help
+# and /usr/share/omf when --enable-desktop-docs is passed to configure. To avoid
+# file conflict and pointless duplication, gnome-desktop:2[doc] will simply use
+# the files that are installed by :3[doc]
+# Note: depend on glib-2.34 to make sure users upgrade glib before gnome-desktop
+# to get a fix for bug #450930
+RDEPEND=">=x11-libs/gtk+-2.18:2
+ >=dev-libs/glib-2.34:2
+ >=x11-libs/libXrandr-1.2
+ >=gnome-base/gconf-2:2
+ >=x11-libs/startup-notification-0.5
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ >=app-text/gnome-doc-utils-0.3.2
+ ~app-text/docbook-xml-dtd-4.1.2
+ x11-proto/xproto
+ >=x11-proto/randrproto-1.2
+"
+PDEPEND=">=dev-python/pygtk-2.8:2[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.14:2[${PYTHON_USEDEP}]
+ license-docs? ( gnome-base/gnome-desktop:3[doc(+)] )
+"
+
+# Includes X11/Xatom.h in libgnome-desktop/gnome-bg.c which comes from xproto
+# Includes X11/extensions/Xrandr.h that includes randr.h from randrproto (and
+# eventually libXrandr shouldn't RDEPEND on randrproto)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gold.patch
+ epatch "${FILESDIR}"/${P}-thumbnails.patch #450930
+ gnome2_src_prepare
+}
+
+src_configure() {
+ python_export_best
+ gnome2_src_configure \
+ --with-gnome-distributor=Gentoo \
+ --disable-scrollkeeper \
+ --disable-static \
+ --disable-deprecations \
+ --disable-desktop-docs
+ # desktop-docs will be built by gnome-desktop:3
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ gnome2_src_install
+ # python-r1.eclass doesn't like versioned python shebangs
+ sed -e 's@#!\(.*python.*\)@#!/usr/bin/env python@' -i gnome-about/gnome-about
+ python_doscript gnome-about/gnome-about
+}