summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-09-28 00:36:24 +0300
committerMart Raudsepp <leio@gentoo.org>2018-09-28 16:49:13 +0300
commit4f874177a1bcee5a10fde56cd58ab5860a7a07b8 (patch)
treec1c7e9247cb1b0f114c253bda395d1b69aa7beed /gnome-base/gnome-shell/files
parentx11-wm/mutter: bump to 3.26.2 (diff)
downloadgentoo-4f874177a1bcee5a10fde56cd58ab5860a7a07b8.tar.gz
gentoo-4f874177a1bcee5a10fde56cd58ab5860a7a07b8.tar.bz2
gentoo-4f874177a1bcee5a10fde56cd58ab5860a7a07b8.zip
gnome-base/gnome-shell: bump to 3.26.2, support elogind, many tweaks
* Port ebuild to use meson (no autotools upstream anymore) * Support elogind and get rid of unnecessary openrc-force hacks; gnome-shell systemd code only handles journald integration - logging structured data to it itself, instead of plain g_prints and telling it about launched apps, so they get to log under their own identifier instead of gnome-session. The -Denable-systemd option only deals with that, so we can safely just not pass it on non-systemd systems. The suspend support is handled purely via logind dbus interfaces and is build unconditionally - at runtime it is conditional on /run/systemd/seats existing and being accessible, which should be the case with newer elogind (with relevant bugs fixed) by my quick research, but I have not tested personally. Don't make a big deal about lacking suspend and seat inhibition support and just pull in a logind interface provider (techically this is runtime only, but not bothering with a separate DEPEND-free RDEPEND block for elogind). The alternative (to require logind) would be to require one of the systemd or elogind USE flags instead of at-most-one-of, but this is runtime optional anyways, so don't block it - user could just build with systemd and boot with something else, for example, and similarly not have this work at runtime). Also remove some ewarns appropriately. * Build-time depend on systemd with USE=systemd for the aforementioned journald integration, which needs systemd present at build time already. * More appropriately use python-single-r1 instead of python-r1 for the two small python utilities. Hack meson to update to the correct shebang. * Make telepathy optional - it was made runtime optional in 3.24 already, and with empathy being in the state it's in, the chat integration is rather unused on a desktop system. * Remove questionable glib USE=dbus requirement - if dconf is required, it should be depended upon directly; but as this is just your typical GSettings memory vs dconf backend scenario, I don't see why that'd be. * Remove unnecessary libXtst depend - I can't find any usage of it in current version (only mentions of caribou using it, which has its own dep and is optional on-screen keyboard support, gone in newer versions). * Move dbus-glib depend inside USE=networkmanager, as this legacy thing is for some reason (instead of GDbus) still used only in a NM specific source file that doesn't get compiled with USE=-networkmanager afaics. * Require introspection on nm-applet with USE=networkmanager, as NMGtk GIR is used. * Remove bogus mesa-progs depend - no glxinfo/glxgears usages here. * Add glib-utils build depend. * Drop dejavu font depend - I don't think we should be pulling in a specific font these days for some glyphs; and if we should, then it probably should be cantarell. * Require USE=glib on pulseaudio, as libpulse-mainloop-glib is linked to in a subproject, not just libpulse. * Simplify the pax-mark logic, as we don't use so old spidermonkey for so long, and pax-mark stuff is not tested by us. But the old complicated conditionals don't apply in many cases, so simplify it to just the common case. Additionally newer spidermonkey (60) will lose jit USE flag and have that unconditional on arches where it's supported, so these conditionals will then result in wrong code paths being taken. Therefore just simplify it to the basics and hope it works and rely on any incoming bugs about it to modernize this. Closes: https://bugs.gentoo.org/655426 Closes: https://bugs.gentoo.org/553966 Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'gnome-base/gnome-shell/files')
-rw-r--r--gnome-base/gnome-shell/files/3.26-optional-bluetooth.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/gnome-base/gnome-shell/files/3.26-optional-bluetooth.patch b/gnome-base/gnome-shell/files/3.26-optional-bluetooth.patch
new file mode 100644
index 000000000000..9f7e5aea4da3
--- /dev/null
+++ b/gnome-base/gnome-shell/files/3.26-optional-bluetooth.patch
@@ -0,0 +1,73 @@
+From 7ca3e1a9d18e6f6154b4479bcd94d420bc69798c Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Mon, 10 Sep 2018 13:17:39 +0200
+Subject: [PATCH] Make bluetooth support optional
+
+https://bugs.gentoo.org/show_bug.cgi?id=398145
+leio: Fixed enable_bluetooth get_option string
+---
+ js/misc/meson.build | 2 +-
+ meson.build | 15 ++++++++++++++-
+ meson_options.txt | 7 +++++++
+ 3 files changed, 22 insertions(+), 2 deletions(-)
+
+diff --git a/js/misc/meson.build b/js/misc/meson.build
+index 20489496c..3071f9dfb 100644
+--- a/js/misc/meson.build
++++ b/js/misc/meson.build
+@@ -3,7 +3,7 @@ jsconf.set('PACKAGE_NAME', meson.project_name())
+ jsconf.set('PACKAGE_VERSION', meson.project_version())
+ jsconf.set('GETTEXT_PACKAGE', meson.project_name())
+ jsconf.set('LIBMUTTER_API_VERSION', mutter_api_version)
+-jsconf.set10('HAVE_BLUETOOTH', bt_dep.found())
++jsconf.set10('HAVE_BLUETOOTH', have_bluetooth)
+ jsconf.set10('HAVE_NETWORKMANAGER', have_networkmanager)
+ jsconf.set('datadir', datadir)
+ jsconf.set('libexecdir', libexecdir)
+diff --git a/meson.build b/meson.build
+index b82c41398..7d342ff61 100644
+--- a/meson.build
++++ b/meson.build
+@@ -91,7 +91,20 @@ startup_dep = dependency('libstartup-notification-1.0', version: startup_req)
+ x11_dep = dependency('x11')
+ schemas_dep = dependency('gsettings-desktop-schemas', version: schemas_req)
+
+-bt_dep = dependency('gnome-bluetooth-1.0', version: bt_req, required: false)
++bt_dep = []
++enable_bluetooth = get_option('enable-bluetooth')
++if enable_bluetooth != 'no'
++ want_bluetooth = enable_bluetooth == 'yes'
++ bt_dep = dependency('gnome-bluetooth-1.0', version: bt_req, required: want_bluetooth)
++ have_bluetooth = bt_dep.found()
++
++ if not have_bluetooth
++ bt_dep = []
++ endif
++else
++ have_bluetooth = false
++endif
++
+ gst_dep = dependency('gstreamer-1.0', version: gst_req, required: false)
+ gst_base_dep = dependency('gstreamer-base-1.0', required: false)
+
+diff --git a/meson_options.txt b/meson_options.txt
+index 18899ffdb..9191f8c0e 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -16,6 +16,13 @@ option('enable-man',
+ description: 'Generate man pages'
+ )
+
++option('enable-bluetooth',
++ type: 'combo',
++ choices: ['yes', 'no', 'auto'],
++ value: 'auto',
++ description: 'Enable bluetooth support'
++)
++
+ option('enable-networkmanager',
+ type: 'combo',
+ choices: ['yes', 'no', 'auto'],
+--
+2.18.0
+