summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2022-03-13 19:20:42 +0200
committerMart Raudsepp <leio@gentoo.org>2022-03-13 19:41:07 +0200
commit086602067559fa450eeb6d366e120983c074ff10 (patch)
treef2ba57d86d6aa9c8d7ab5790a611ab72613fbec6 /gnome-base
parentdev-db/mysql-cluster: drop 7.2.34, 7.3.22 (diff)
downloadgentoo-086602067559fa450eeb6d366e120983c074ff10.tar.gz
gentoo-086602067559fa450eeb6d366e120983c074ff10.tar.bz2
gentoo-086602067559fa450eeb6d366e120983c074ff10.zip
gnome-base/librsvg: bump to 2.52.7
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/librsvg/Manifest1
-rw-r--r--gnome-base/librsvg/librsvg-2.52.7.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/gnome-base/librsvg/Manifest b/gnome-base/librsvg/Manifest
index 6300dee6e51b..bcc8e1fa24b5 100644
--- a/gnome-base/librsvg/Manifest
+++ b/gnome-base/librsvg/Manifest
@@ -2,3 +2,4 @@ DIST librsvg-2.40.21.tar.xz 1655860 BLAKE2B a3fd7915d39984057e860da90115d9d95cef
DIST librsvg-2.50.7.tar.xz 22224148 BLAKE2B 323d8125d73c9e72fefe7a868783f16332fb9e047963ccc0c36af280dc5ca4e1f6df3eee8b28b2380140634f51c1acf5b71fc496dd584ed9abf6ca3ebbb9f4c7 SHA512 064df9440802088f4414ffb70e5115809028858065739443444e5eaf6f809da47c697d31f9423e3ce9efcdeea02ff41ec39f5acf5882f2d35f433b7565be3c16
DIST librsvg-2.52.5.tar.xz 23273740 BLAKE2B f158fa0b16bed176ef5a687b448707906019ad62177029c1165abb0a7f1d1bbe8a8b2809ccab0a49c19e23dd6f949667db533e1010b21b4bed14506c72a1cca8 SHA512 00acfe6f3b4912b393fa3d73bcea5d2a6eb04a34cd297c66cc633b35f26bee622093620fcd038ce64ff1712ec86cd19c2cc5ec782d024b56d2605e37fdc3733d
DIST librsvg-2.52.6.tar.xz 23662708 BLAKE2B 21108297aa4f87a852d0decb9cc7b8a5cdb546e00075d16f0f86502752adc176a67b56607eb90b034ca4e2dddbf8f82a3d81727496a5ae1a2b94715cdbbd87ac SHA512 be4830fb34c4859bdbe0c86da7b5de0807f28bb63fc124b4405ca8f9ef6ee45add77b4c43b9031d00157870eceb458df30cf5ee25e73d3894797d622b465f38d
+DIST librsvg-2.52.7.tar.xz 23709632 BLAKE2B 4eb83d71b77b851c408ddba711fe39ed23863aa6466634020a19ffc30e00c12f7dea81f11fdc09eb53c0c72efb35adc4528568b3c27e5dc0e886426d145d347f SHA512 15c075d696ebba35555f93456be088e6398da5b7992119edc78f1ee1d376a70425248e36b138dc86234aec13cb139fded11d6d74523c44f9a49eb19c2151fcb7
diff --git a/gnome-base/librsvg/librsvg-2.52.7.ebuild b/gnome-base/librsvg/librsvg-2.52.7.ebuild
new file mode 100644
index 000000000000..083436b27fac
--- /dev/null
+++ b/gnome-base/librsvg/librsvg-2.52.7.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION=0.46
+
+inherit gnome2 multilib-minimal rust-toolchain vala
+
+DESCRIPTION="Scalable Vector Graphics (SVG) rendering library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibRsvg"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="+introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=x11-libs/cairo-1.16.0[glib,svg,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.9:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.20:2[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.50.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.0.0:=[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.46.0[${MULTILIB_USEDEP}]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+"
+DEPEND="${RDEPEND}
+ >=virtual/rust-1.52[${MULTILIB_USEDEP}]
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+# >=gtk-doc-am-1.13, gobject-introspection-common, vala-common needed by eautoreconf
+
+QA_FLAGS_IGNORED="
+ usr/bin/rsvg-convert
+ usr/lib.*/librsvg.*
+"
+
+RESTRICT="test" # Lots of issues on 32bit builds, 64bit build seems to get into an infinite compilation sometimes, etc.
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --disable-static
+ --disable-debug
+ $(multilib_native_use_enable introspection)
+ $(multilib_native_use_enable vala)
+ --enable-pixbuf-loader
+ )
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ # Set the rust target, which can differ from CHOST
+ RUST_TARGET="$(rust_abi)"
+ # RUST_TARGET is only honored if cross_compiling, but non-native ABIs aren't cross as
+ # far as C parts and configure auto-detection are concerned as CHOST equals CBUILD
+ cross_compiling=yes
+ )
+ fi
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure "${myconf[@]}"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_compile() {
+ # causes segfault if set, see bug #411765
+ unset __GL_NO_DSO_FINALIZER
+ gnome2_src_compile
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+ multilib_foreach_abi gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+ multilib_foreach_abi gnome2_pkg_postrm
+}