summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-20 10:27:29 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-20 12:54:06 -0700
commit3496a3738d4a9eb979a0c7622f9d03011a23430c (patch)
tree8288110316017804ea3ffbf5b204b14605b02174 /gnome-base
parentdev-libs/gjs: Version bump to 1.72.0 (diff)
downloadgentoo-3496a3738d4a9eb979a0c7622f9d03011a23430c.tar.gz
gentoo-3496a3738d4a9eb979a0c7622f9d03011a23430c.tar.bz2
gentoo-3496a3738d4a9eb979a0c7622f9d03011a23430c.zip
gnome-base/gsettings-desktop-schemas: Version bump to 42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gsettings-desktop-schemas/Manifest1
-rw-r--r--gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-42.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/gnome-base/gsettings-desktop-schemas/Manifest b/gnome-base/gsettings-desktop-schemas/Manifest
index aa1479aacd00..7aadf617f5e6 100644
--- a/gnome-base/gsettings-desktop-schemas/Manifest
+++ b/gnome-base/gsettings-desktop-schemas/Manifest
@@ -1 +1,2 @@
DIST gsettings-desktop-schemas-41.0.tar.xz 705240 BLAKE2B 2f2eb797fbdb7317666839a4ddffd65405ddcca80724a480bd1decfc164acc4c0db193ca6a3e3bcd71fbeb479fe51c5262c0bcf40fe85cfb2d6bda5b47d5b6e5 SHA512 58f9f60d818f0ddce20ad70e6ca64d3e1fb5a5dfd45b737cc055901f7dd5f1625902451e765a26969bdd72e3b37300dacbd3555a4bc3f33c6667dbf9b1869739
+DIST gsettings-desktop-schemas-42.0.tar.xz 709372 BLAKE2B abe682b32dc3c419a65b3752b9fa6821ed0058f06a4b123728a8d095ff3b6f65b569d9b80d43aac28fa5d79439c316cb628f0c63cd500c7ebc40cc4eff704bdb SHA512 db73988a6b38857d1aa6588ccac42099c57dcc187ef01776567cc7c28aff67dc06d6a8a067e0c69167d03cd865f0c1d58e75469a40f969084bb2537b088f8664
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-42.0.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-42.0.ebuild
new file mode 100644
index 000000000000..9af8626a7cbc
--- /dev/null
+++ b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-42.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
+
+BDEPEND="
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ # Revert change to 'Source Code Pro 10' and 'Cantarell 11' fonts back to generic sans and monospace aliases
+ "${FILESDIR}"/3.32.0-default-fonts.patch
+)
+
+src_prepare() {
+ default
+
+ python_fix_shebang build-aux/meson/post-install.py
+}
+
+src_configure() {
+ meson_src_configure $(meson_use introspection)
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}