summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-03-06 14:38:39 +0100
committerPacho Ramos <pacho@gentoo.org>2016-03-06 14:38:39 +0100
commit4259ca5fca9adbf3fb44c22eed90a54d16983ba9 (patch)
treedecc6b81d54629c83fb192ff733bbc862211c889 /gnome-base
parentwww-client/seamonkey: Bump to version 2.40_pre4 (with additional graphite2 fix) (diff)
downloadgentoo-4259ca5fca9adbf3fb44c22eed90a54d16983ba9.tar.gz
gentoo-4259ca5fca9adbf3fb44c22eed90a54d16983ba9.tar.bz2
gentoo-4259ca5fca9adbf3fb44c22eed90a54d16983ba9.zip
gnome-base/gnome-extra-apps: Cantarell upstream is relying in extra fonts (https://bugzilla.gnome.org/show_bug.cgi?id=762890). Pull them from here to let people willing to have missing fonts to avoid them simply using gnome-base/gnome[-extras] but include them for the others as, currently, people will simply see missing characters and no information about how to solve that.
Package-Manager: portage-2.2.27
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-extra-apps/gnome-extra-apps-3.18.0-r2.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/gnome-base/gnome-extra-apps/gnome-extra-apps-3.18.0-r2.ebuild b/gnome-base/gnome-extra-apps/gnome-extra-apps-3.18.0-r2.ebuild
new file mode 100644
index 000000000000..bf91585b28a8
--- /dev/null
+++ b/gnome-base/gnome-extra-apps/gnome-extra-apps-3.18.0-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Sub-meta package for the applications of GNOME 3"
+HOMEPAGE="https://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="3.0"
+IUSE="+games +share +shotwell +tracker"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~amd64 ~x86"
+
+# Note to developers:
+# This is a wrapper for the extra apps integrated with GNOME 3
+# New package
+#
+# cantarell upstream relies on noto, unifont and symbola fonts for
+# the fonts they cannot handle due to lack of enough manpower:
+# https://bugzilla.gnome.org/show_bug.cgi?id=762890
+RDEPEND="
+ >=gnome-base/gnome-core-libs-${PV}
+
+ >=app-admin/gnome-system-log-3.9.90
+ >=app-arch/file-roller-3.16.4
+ >=app-dicts/gnome-dictionary-${PV}
+ >=gnome-base/dconf-editor-${PV}
+ >=gnome-extra/gconf-editor-3
+ >=gnome-extra/gnome-calculator-${PV}
+ >=gnome-extra/gnome-calendar-${PV}
+ >=gnome-extra/gnome-characters-${PV}
+ >=gnome-extra/gnome-power-manager-${PV}
+ >=gnome-extra/gnome-search-tool-3.6
+ >=gnome-extra/gnome-system-monitor-${PV}
+ >=gnome-extra/gnome-tweak-tool-${PV}
+ >=gnome-extra/gnome-weather-${PV}
+ >=gnome-extra/gucharmap-${PV}:2.90
+ >=gnome-extra/nautilus-sendto-3.8.2
+ >=gnome-extra/sushi-${PV}
+ >=mail-client/evolution-${PV}
+ >=media-gfx/gnome-font-viewer-3.16.2
+ >=media-gfx/gnome-screenshot-${PV}
+ >=media-sound/sound-juicer-${PV}
+ >=media-video/cheese-${PV}
+ >=net-analyzer/gnome-nettool-3.8
+ >=net-misc/vinagre-${PV}
+ >=net-misc/vino-${PV}
+ >=sys-apps/baobab-${PV}
+ >=sys-apps/gnome-disk-utility-${PV}
+ >=www-client/epiphany-${PV}
+
+ >=media-fonts/noto-20160305
+ >=media-fonts/symbola-8.00
+ >=media-fonts/unifont-8.0.01
+
+ games? (
+ >=games-arcade/gnome-nibbles-${PV}
+ >=games-arcade/gnome-robots-${PV}
+ >=games-board/four-in-a-row-${PV}
+ >=games-board/gnome-chess-${PV}
+ >=games-board/gnome-mahjongg-${PV}
+ >=games-board/gnome-mines-${PV}
+ >=games-board/iagno-${PV}
+ >=games-board/tali-${PV}
+ >=games-puzzle/five-or-more-${PV}
+ >=games-puzzle/gnome-klotski-${PV}
+ >=games-puzzle/gnome-sudoku-${PV}
+ >=games-puzzle/gnome-taquin-${PV}
+ >=games-puzzle/gnome-tetravex-${PV}
+ >=games-puzzle/hitori-3.16.2
+ >=games-puzzle/lightsoff-${PV}
+ >=games-puzzle/quadrapassel-${PV}
+ >=games-puzzle/swell-foop-${PV} )
+ share? ( >=gnome-extra/gnome-user-share-${PV} )
+ shotwell? ( >=media-gfx/shotwell-0.22 )
+ tracker? (
+ >=app-misc/tracker-1.6
+ >=gnome-extra/gnome-documents-${PV}
+ >=media-gfx/gnome-photos-${PV}
+ >=media-sound/gnome-music-${PV} )
+"
+DEPEND=""
+S=${WORKDIR}