summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-11-08 20:33:25 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-08 20:54:27 -0500
commit4f7317dfb96366e5cf2f8c0fc286368558787609 (patch)
tree6843947b450568337d78e58b6d7bb105b3f89851 /gnome-base
parentx11-libs/libXfixes: Move x11-proto/xorg-proto to DEPEND (diff)
downloadgentoo-4f7317dfb96366e5cf2f8c0fc286368558787609.tar.gz
gentoo-4f7317dfb96366e5cf2f8c0fc286368558787609.tar.bz2
gentoo-4f7317dfb96366e5cf2f8c0fc286368558787609.zip
gnome-base/gsettings-desktop-schemas: Version bump to 3.38.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gsettings-desktop-schemas/Manifest1
-rw-r--r--gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.38.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/gnome-base/gsettings-desktop-schemas/Manifest b/gnome-base/gsettings-desktop-schemas/Manifest
index 8a0f8c9734fa..147df8952c49 100644
--- a/gnome-base/gsettings-desktop-schemas/Manifest
+++ b/gnome-base/gsettings-desktop-schemas/Manifest
@@ -1,2 +1,3 @@
DIST gsettings-desktop-schemas-3.34.0.tar.xz 650468 BLAKE2B a275cd011c255531b293ccb875159ea4465c79852a3d1be2a03faafa8dbb6ba7137d72c7a59bce93b6ce5f187ebf92aca334dc3c51c8de5ee3af3092fc250fe5 SHA512 6cbe59facf77566ed93faabafc6b00ad03fb398a9a4686ba94a08b1c2d0df1d44bd673fb4d51340209a66ebc0aa32095615e7e63b78f4cc4c10d240a7b0a8fa1
DIST gsettings-desktop-schemas-3.36.1.tar.xz 679788 BLAKE2B f49f98274f48cdb2eab0d3d94147cc0994245156999d5ed71adbbe4c949bb4da1ba230fe185938542b9854c77b6e0d7084d1919c26bf9939cd58baf4fcc8f129 SHA512 623a3759fe84cc5ea897043cc7c337a4f83302ebe5cfb9d214210a48e460e22b180518f5d768382ec18396bb2e86f22649dbc9b367a858e56b1ee8d2cab58fa8
+DIST gsettings-desktop-schemas-3.38.0.tar.xz 685868 BLAKE2B a5fe8baf6d7178cfba74c82974dfb854fbc2accfb9c98db2edbf46271b54626150a570fb3b578cdd86acfd1b21b432da0947e273c3ab94ec3f416c4a51b44e4a SHA512 5af7da90b8e7eec1c98e9e44653955f2882961dd9b5e2bf00e4eeb9f4f1149ae5171c600d457c6ab9c7482471c1a0e98f92f645a7ee7298e1b843c608f660756
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.38.0.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.38.0.ebuild
new file mode 100644
index 000000000000..34729655bb54
--- /dev/null
+++ b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.38.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
+HOMEPAGE="https://git.gnome.org/browse/gsettings-desktop-schemas"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
+
+BDEPEND="
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Revert change to 'Source Code Pro 10' and 'Cantarell 11' fonts back to generic sans and monospace aliases
+ "${FILESDIR}"/3.32.0-default-fonts.patch
+)
+
+src_configure() {
+ meson_src_configure $(meson_use introspection)
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}