summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-13 11:08:03 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-13 11:26:21 -0500
commit61df03d83de73902fd6adb6d268e0b0f1aaa7064 (patch)
tree14a948414bba475194fe80d9091c30713cb36f9b /gnome-base
parentnet-libs/mbedtls: version bump to 2.16.10, 2.26.0 (diff)
downloadgentoo-61df03d83de73902fd6adb6d268e0b0f1aaa7064.tar.gz
gentoo-61df03d83de73902fd6adb6d268e0b0f1aaa7064.tar.bz2
gentoo-61df03d83de73902fd6adb6d268e0b0f1aaa7064.zip
gnome-base/dconf: Version bump to 0.40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/dconf/Manifest1
-rw-r--r--gnome-base/dconf/dconf-0.40.0.ebuild83
-rw-r--r--gnome-base/dconf/files/0.40.0-bash-completion-dir.patch68
3 files changed, 152 insertions, 0 deletions
diff --git a/gnome-base/dconf/Manifest b/gnome-base/dconf/Manifest
index 823d9fc3c29f..393eec0e90f9 100644
--- a/gnome-base/dconf/Manifest
+++ b/gnome-base/dconf/Manifest
@@ -1,2 +1,3 @@
DIST dconf-0.34.0.tar.xz 112876 BLAKE2B 6890cd82a3ba81eac8c72dda93ebf1b82f3002b735bf2e059ba07a2f0f3817978a9e4f5dd37a9efab728fc2a4e20c34c519f9eeb3915d705ff8a3c4a65f9ab41 SHA512 8b28373f31fe36ba3f21f56fca84563681c3648ff595709880cd9ac49fc6b130ac375fb89fd585f1dd62b5a2f728127292ea57d18feca1147b709a93e8c4c743
DIST dconf-0.36.0.tar.xz 114828 BLAKE2B 033cb2e095d9dac72bd07c5fa8280a3e1012aac6c1b0657d5455c2a519617be9112acca702ec4078554a814f36d12ee8e25201cc5b8aed2d33a32ef14e2f6fa5 SHA512 fed0b4ac13dfeff3bbe428a5c25408a0f13610219e561841a3af75cf18f9c630c385989b700c081b79ab53c00bdecf43c7c94979312c047faefbda4b2653d40d
+DIST dconf-0.40.0.tar.xz 117764 BLAKE2B bdbc48b71e46fdc4353358cd08fb96933d07af587300a6f91bc45826aeafb3f34f482fe6e09041dd839e507b863a8e33d09bad88a91c1c868983f8afb52c5c85 SHA512 71396d71f24f47653181482b052fdfc63795c50c373de34e2fb93e16101745daa7e81192b79a102d5389911cea34138eedf3ac32bc80562018e8a7f31963559a
diff --git a/gnome-base/dconf/dconf-0.40.0.ebuild b/gnome-base/dconf/dconf-0.40.0.ebuild
new file mode 100644
index 000000000000..d0515385aa74
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.40.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 gnome.org gnome2-utils meson systemd virtualx xdg
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/Projects/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="gtk-doc"
+RESTRICT="!test? ( test )" # IUSE=test comes from virtualx.eclass
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ sys-apps/dbus
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ gtk-doc? ( >=dev-util/gtk-doc-1.15 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/0.40.0-bash-completion-dir.patch
+ "${FILESDIR}"/0.32.0-drop-vapigen-dep.patch # .vapi/.deps are pregenerated, just install them without a vala dep
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dbash_completion_dir="$(get_bashcompdir)"
+ -Dman=true
+ $(meson_use gtk-doc gtk_doc)
+ -Dvapi=true
+ -Dsystemduserunitdir=$(systemd_get_userunitdir)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # GSettings backend may be one of: memory, gconf, dconf
+ # Only dconf is really considered functional by upstream
+ # must have it enabled over gconf if both are installed
+ # This snippet can't be removed until gconf package is
+ # ensured to not install a /etc/env.d/50gconf and then
+ # still consider the CONFIG_PROTECT_MASK bit.
+ echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+ doenvd 51dconf
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_giomodule_cache_update
+
+ # Kill existing dconf-service processes as recommended by upstream due to
+ # possible changes in the dconf private dbus API.
+ # dconf-service will be dbus-activated on next use.
+ pids=$(pgrep -x dconf-service)
+ if [[ $? == 0 ]]; then
+ ebegin "Stopping dconf-service; it will automatically restart on demand"
+ kill ${pids}
+ eend $?
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_giomodule_cache_update
+}
diff --git a/gnome-base/dconf/files/0.40.0-bash-completion-dir.patch b/gnome-base/dconf/files/0.40.0-bash-completion-dir.patch
new file mode 100644
index 000000000000..43bbe57294d9
--- /dev/null
+++ b/gnome-base/dconf/files/0.40.0-bash-completion-dir.patch
@@ -0,0 +1,68 @@
+From 43393af96308d001c30ac14c32000519253fe910 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Fri, 22 Feb 2019 22:06:18 +0200
+Subject: [PATCH] build: Allow passing bash-completion dir and have a generic
+ fallback
+
+With autotools the installation path was just hardcoded to the usual
+location. In meson it was made to always check the path from
+bash-completion.pc, but some downstream might want to install the
+file without a bash-completion build-dep. Allow installing the
+completion file to a passed directory, and add back the fallback
+path if an explicit directory isn't passed and bash-completion
+package isn't found. This is also what the tracker project does.
+---
+ meson.build | 26 ++++++++++++++++++--------
+ meson_options.txt | 2 +-
+ 2 files changed, 19 insertions(+), 9 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index b81a81a..7c790c1 100644
+--- a/meson.build
++++ b/meson.build
+@@ -62,14 +62,24 @@ if systemd_userunitdir == ''
+ endif
+ endif
+
+-enable_bash_completion = get_option('bash_completion')
+-if enable_bash_completion
+- bash_completion_dep = dependency('bash-completion')
+- completions_dir = bash_completion_dep.get_pkgconfig_variable(
+- 'completionsdir',
+- # bash-completion 2.10 changed the substitutions
+- define_variable: bash_completion_dep.version().version_compare('>= 2.10') ? ['datadir', dconf_datadir] : ['prefix', dconf_prefix],
+- )
++enable_bash_completion = false
++if get_option('bash_completion_dir') == 'yes' or get_option('bash_completion_dir') == 'auto'
++ bash_completion_dep = dependency('bash-completion', required: false)
++ if bash_completion_dep.found()
++ completions_dir = bash_completion_dep.get_pkgconfig_variable(
++ 'completionsdir',
++ # bash-completion 2.10 changed the substitutions
++ define_variable: bash_completion_dep.version().version_compare('>= 2.10') ? ['datadir', dconf_datadir] : ['prefix', dconf_prefix],
++ )
++ else
++ completions_dir = join_paths(dconf_datadir, 'bash-completion', 'completions')
++ endif
++ enable_bash_completion = true
++elif get_option('bash_completion_dir') == 'no' or get_option('bash_completion_dir') == ''
++ enable_bash_completion = false
++else
++ enable_bash_completion = true
++ completions_dir = get_option('bash_completion_dir')
+ endif
+
+ configure_file(
+diff --git a/meson_options.txt b/meson_options.txt
+index 1b85d5d..7f5afcc 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,4 +1,4 @@
+-option('bash_completion', type: 'boolean', value: true, description: 'install bash completion files')
++option('bash_completion_dir', type: 'string', value: 'yes', description: 'directory to install Bash completion files (or "yes" for default directory, "no" to disable installation)')
+ option('man', type: 'boolean', value: true, description: 'generate man pages')
+ option('gtk_doc', type: 'boolean', value: false, description: 'use gtk-doc to build documentation')
+ option('vapi', type: 'boolean', value: true, description: 'install dconf client vapi')
+--
+2.26.2
+