summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-22 23:12:41 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-22 23:14:35 -0700
commit72c94dab3debdbe8eddb02df923ba0b91a0473b5 (patch)
treeada1fe76cb81512b4a2f38c4919613ecb7d5fe39 /gnome-base
parentgnome-base/gnome-session: Version bump to 42.0 (diff)
downloadgentoo-72c94dab3debdbe8eddb02df923ba0b91a0473b5.tar.gz
gentoo-72c94dab3debdbe8eddb02df923ba0b91a0473b5.tar.bz2
gentoo-72c94dab3debdbe8eddb02df923ba0b91a0473b5.zip
gnome-base/gnome-settings-daemon: Version bump to 42.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-settings-daemon/Manifest1
-rw-r--r--gnome-base/gnome-settings-daemon/files/42.1-build-Make-wacom-optional-and-controllable-via-meson.patch40
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-42.1.ebuild147
3 files changed, 188 insertions, 0 deletions
diff --git a/gnome-base/gnome-settings-daemon/Manifest b/gnome-base/gnome-settings-daemon/Manifest
index 70eeb5a866c5..a0ec3b528cb3 100644
--- a/gnome-base/gnome-settings-daemon/Manifest
+++ b/gnome-base/gnome-settings-daemon/Manifest
@@ -1 +1,2 @@
DIST gnome-settings-daemon-41.0.tar.xz 1477876 BLAKE2B f17005b03cbee142434f0805e8f590d6d9edad0f09b3226bb40ab7e312ee13bcd46c211efb140303d4a351d8818238a28bd9aa3fe760fb617fb006e97eebde61 SHA512 2c6848a749f84fd0c3a9ade6f4a83ae3ff7464da429b2d73030c9dcbd278b070c40475c678c819e31464941f2bd38d81f11b96f24d0d1fb05271267c3a1ecc2a
+DIST gnome-settings-daemon-42.1.tar.xz 1481432 BLAKE2B d045b2e2a17c6c54f0014db03e1b2d645086d907383b849de82f972af39463acf06ab1207817f171fd3b7a33b60303d058f04495158bb49aab7899da740f732c SHA512 20e87fc2318d77af016ec071cc6070f43ac42eaaf60a1f9bdb4278f59e038268e0a37759f0ab31068d8701b9dc64d142c0a875f0eeaa700ad47e0dbca3b9d141
diff --git a/gnome-base/gnome-settings-daemon/files/42.1-build-Make-wacom-optional-and-controllable-via-meson.patch b/gnome-base/gnome-settings-daemon/files/42.1-build-Make-wacom-optional-and-controllable-via-meson.patch
new file mode 100644
index 000000000000..3956b7413978
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/42.1-build-Make-wacom-optional-and-controllable-via-meson.patch
@@ -0,0 +1,40 @@
+From 1e07481d4fd989828a7237c365e5420f50196ddd Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Thu, 14 Mar 2019 09:43:00 +0200
+Subject: [PATCH] build: Make wacom optional and controllable via meson_options
+
+---
+ meson.build | 4 ++--
+ meson_options.txt | 1 +
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index a8955a49..0ac4f3ba 100644
+--- a/meson.build
++++ b/meson.build
+@@ -154,8 +154,8 @@ if enable_wayland
+ endif
+ config_h.set10('HAVE_WAYLAND', enable_wayland)
+
+-# wacom (disabled for s390/s390x and non Linux platforms)
+-enable_wacom = host_is_linux_not_s390
++# wacom
++enable_wacom = get_option('wacom')
+ if enable_wacom
+ assert(enable_gudev, 'GUDev support is required for wacom support.')
+ libwacom_dep = dependency('libwacom', version: '>= 0.7')
+diff --git a/meson_options.txt b/meson_options.txt
+index 3e04cf64..010053e2 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -9,6 +9,7 @@ option('network_manager', type: 'boolean', value: true, description: 'build with
+ option('rfkill', type: 'boolean', value: true, description: 'build with rfkill support (not optional on Linux platforms)')
+ option('smartcard', type: 'boolean', value: true, description: 'build with smartcard support')
+ option('usb-protection', type: 'boolean', value: true, description: 'build with usb-protection support')
++option('wacom', type: 'boolean', value: true, description: 'build with Wacom devices support')
+ option('wayland', type: 'boolean', value: true, description: 'build with Wayland support')
+ option('wwan', type: 'boolean', value: true, description: 'build with WWAN support')
+ option('colord', type: 'boolean', value: true, description: 'build with colord support')
+--
+2.34.1
+
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-42.1.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-42.1.ebuild
new file mode 100644
index 000000000000..43fc4b23d465
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-42.1.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org gnome2-utils python-any-r1 meson udev virtualx xdg
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+colord +cups debug elogind input_devices_wacom modemmanager networkmanager smartcard systemd test +udev wayland"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ ^^ ( elogind systemd )
+ input_devices_wacom? ( udev )
+ wayland? ( udev )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+DEPEND="
+ >=sci-geosciences/geocode-glib-3.10
+ >=dev-libs/glib-2.58:2
+ >=gnome-base/gnome-desktop-3.37.1:3=
+ >=gnome-base/gsettings-desktop-schemas-42
+ >=x11-libs/gtk+-3.15.3:3[X,wayland?]
+ >=dev-libs/libgweather-4.0.0:4=
+ colord? (
+ >=x11-misc/colord-1.4.5:=
+ >=media-libs/lcms-2.2:2
+ )
+ media-libs/libcanberra[gtk3]
+ >=app-misc/geoclue-2.3.1:2.0
+ >=x11-libs/libnotify-0.7.3
+ >=media-sound/pulseaudio-12.99.3[glib]
+ >=sys-auth/polkit-0.114
+ >=sys-power/upower-0.99.12:=
+ x11-libs/libX11
+ >=x11-libs/libXfixes-6.0.0
+ udev? ( dev-libs/libgudev:= )
+ wayland? ( dev-libs/wayland )
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.7
+ >=x11-libs/pango-1.20.0
+ x11-libs/gdk-pixbuf:2
+ )
+ smartcard? ( >=dev-libs/nss-3.11.2 )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ modemmanager? (
+ >=app-crypt/gcr-3.7.5:=
+ >=net-misc/modemmanager-1.0:=
+ )
+ networkmanager? ( >=net-misc/networkmanager-1.0 )
+ media-libs/alsa-lib
+ x11-libs/libXi
+ x11-libs/libXext
+ media-libs/fontconfig
+ systemd? (
+ >=sys-apps/systemd-243
+ )
+"
+# logind needed for power and session management, bug #464944
+# gnome-session-3.33.90/gdm-3.33.90/gnome-shell-extensions-3.34.1/gnome-flashback-3.33.1 adapt to Clipboard and Mouse component removals (moved to mutter)
+RDEPEND="${DEPEND}
+ gnome-base/dconf
+ elogind? ( sys-auth/elogind )
+ !<gnome-base/gnome-session-3.33.90
+ !<gnome-base/gdm-3.33.90
+ !<gnome-extra/gnome-shell-extensions-3.34.1
+ !<gnome-base/gnome-flashback-3.33.1
+"
+# rfkill requires linux/rfkill.h (and USE=udev), thus linux-headers dep, not os-headers. If this package wants to work on other kernels, we need to make rfkill conditional instead
+BDEPEND="
+ sys-kernel/linux-headers
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ x11-base/xorg-proto
+ ${PYTHON_DEPS}
+ test? (
+ $(python_gen_any_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gnome-session
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/42.1-build-Make-wacom-optional-and-controllable-via-meson.patch
+ "${FILESDIR}"/${PN}-3.38.1-build-Allow-NM-optional-on-Linux.patch
+ "${FILESDIR}"/${PN}-3.38.1-Allow-udev-optional-on-Linux.patch
+)
+
+python_check_deps() {
+ if use test; then
+ has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]" &&
+ has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]"
+ fi
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ #-Dnssdb_dir # TODO: Is the default /etc/pki/nssdb path correct for our nss?
+ -Dudev_dir="$(get_udevdir)"
+ $(meson_use systemd)
+ -Dalsa=true
+ $(meson_use udev gudev)
+ $(meson_use colord)
+ $(meson_use cups)
+ $(meson_use networkmanager network_manager)
+ $(meson_use udev rfkill)
+ $(meson_use smartcard)
+ $(meson_use input_devices_wacom wacom)
+ $(meson_use wayland)
+ $(meson_use modemmanager wwan)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ # Don't auto-suspend by default on AC power
+ insinto /usr/share/glib-2.0/schemas
+ doins "${FILESDIR}"/org.gnome.settings-daemon.plugins.power.gschema.override
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}