summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-19 13:06:43 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-19 13:06:43 -0500
commit808474df836eb1c74938d71270c6d763c8694faf (patch)
tree83c45d5ef52641f17b9abc1aa1ec9138b3d8536c /gnome-base
parentgames-puzzle/swell-foop: Version bump to 41.0.1 (diff)
downloadgentoo-808474df836eb1c74938d71270c6d763c8694faf.tar.gz
gentoo-808474df836eb1c74938d71270c6d763c8694faf.tar.bz2
gentoo-808474df836eb1c74938d71270c6d763c8694faf.zip
gnome-base/librsvg: Version bump to 2.52.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/librsvg/Manifest1
-rw-r--r--gnome-base/librsvg/librsvg-2.52.5.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/gnome-base/librsvg/Manifest b/gnome-base/librsvg/Manifest
index ca774f6fc5d5..18ed999c2652 100644
--- a/gnome-base/librsvg/Manifest
+++ b/gnome-base/librsvg/Manifest
@@ -1,2 +1,3 @@
DIST librsvg-2.40.21.tar.xz 1655860 BLAKE2B a3fd7915d39984057e860da90115d9d95cef97e61d3f5e4c3aaaf399c4b3bfe781e6a7b969958ae84a3b7f2c788576fe26f56b037ca0a6a2e059b53f2bd1b9fc SHA512 db0563d8e0edaae642a6b2bcd239cf54191495058ac8c7ff614ebaf88c0e30bd58dbcd41f58d82a9d5ed200ced45fc5bae22f2ed3cf3826e9348a497009e1280
DIST librsvg-2.50.7.tar.xz 22224148 BLAKE2B 323d8125d73c9e72fefe7a868783f16332fb9e047963ccc0c36af280dc5ca4e1f6df3eee8b28b2380140634f51c1acf5b71fc496dd584ed9abf6ca3ebbb9f4c7 SHA512 064df9440802088f4414ffb70e5115809028858065739443444e5eaf6f809da47c697d31f9423e3ce9efcdeea02ff41ec39f5acf5882f2d35f433b7565be3c16
+DIST librsvg-2.52.5.tar.xz 23273740 BLAKE2B f158fa0b16bed176ef5a687b448707906019ad62177029c1165abb0a7f1d1bbe8a8b2809ccab0a49c19e23dd6f949667db533e1010b21b4bed14506c72a1cca8 SHA512 00acfe6f3b4912b393fa3d73bcea5d2a6eb04a34cd297c66cc633b35f26bee622093620fcd038ce64ff1712ec86cd19c2cc5ec782d024b56d2605e37fdc3733d
diff --git a/gnome-base/librsvg/librsvg-2.52.5.ebuild b/gnome-base/librsvg/librsvg-2.52.5.ebuild
new file mode 100644
index 000000000000..26830cf01f9e
--- /dev/null
+++ b/gnome-base/librsvg/librsvg-2.52.5.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION=0.46
+
+inherit gnome2 multilib-minimal rust-toolchain vala
+
+DESCRIPTION="Scalable Vector Graphics (SVG) rendering library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibRsvg"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="+introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=x11-libs/cairo-1.16.0[glib,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.9:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.20:2[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.50.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.0.0:=[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.46.0[${MULTILIB_USEDEP}]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+"
+DEPEND="${RDEPEND}
+ >=virtual/rust-1.52[${MULTILIB_USEDEP}]
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+# >=gtk-doc-am-1.13, gobject-introspection-common, vala-common needed by eautoreconf
+
+RESTRICT="test" # Lots of issues on 32bit builds, 64bit build seems to get into an infinite compilation sometimes, etc.
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --disable-static
+ --disable-debug
+ $(multilib_native_use_enable introspection)
+ $(multilib_native_use_enable vala)
+ --enable-pixbuf-loader
+ )
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ # Set the rust target, which can differ from CHOST
+ RUST_TARGET="$(rust_abi)"
+ # RUST_TARGET is only honored if cross_compiling, but non-native ABIs aren't cross as
+ # far as C parts and configure auto-detection are concerned as CHOST equals CBUILD
+ cross_compiling=yes
+ )
+ fi
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure "${myconf[@]}"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_compile() {
+ # causes segfault if set, see bug #411765
+ unset __GL_NO_DSO_FINALIZER
+ gnome2_src_compile
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+ multilib_foreach_abi gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+ multilib_foreach_abi gnome2_pkg_postrm
+}